Salome HOME
IMP: SMESH: Japanese translations
[modules/smesh.git] / src / StdMeshersGUI / Makefile.am
index aaa37f91feb46c5d766abdd981a60982f16c8386..237a974d7398fa62dfca8d147caed2936aabee97 100644 (file)
@@ -1,24 +1,20 @@
-#  SMESH StdMeshersGUI : GUI for StdMeshers plugin
+# Copyright (C) 2007-2013  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003  CEA
-# 
-#  This library is free software; you can redistribute it and/or 
-#  modify it under the terms of the GNU Lesser General Public 
-#  License as published by the Free Software Foundation; either 
-#  version 2.1 of the License. 
-# 
-#  This library is distributed in the hope that it will be useful, 
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
-#  Lesser General Public License for more details. 
-# 
-#  You should have received a copy of the GNU Lesser General Public 
-#  License along with this library; if not, write to the Free Software 
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
-# 
-# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 #  File   : Makefile.in
 #  Author : Julia DOROVSKIKH
@@ -29,10 +25,22 @@ include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
 salomeinclude_HEADERS = \
-       StdMeshersGUI_StdHypothesisCreator.h
+       StdMeshersGUI_StdHypothesisCreator.h \
+       SMESH_StdMeshersGUI.hxx \
+       StdMeshersGUI_DistrPreview.h \
+       StdMeshersGUI_DistrTable.h \
+       StdMeshersGUI_NbSegmentsCreator.h \
+       StdMeshersGUI_ObjectReferenceParamWdg.h \
+       StdMeshersGUI_QuadrangleParamWdg.h \
+       StdMeshersGUI_LayerDistributionParamWdg.h \
+       StdMeshersGUI_FixedPointsParamWdg.h \
+       StdMeshersGUI_SubShapeSelectorWdg.h \
+       StdMeshersGUI_CartesianParamCreator.h \
+       StdMeshersGUI_RadioButtonsGrpWdg.h
 
 # Libraries targets
 lib_LTLIBRARIES = libStdMeshersGUI.la
+
 dist_libStdMeshersGUI_la_SOURCES = \
        StdMeshersGUI.cxx \
        StdMeshersGUI_StdHypothesisCreator.cxx \
@@ -40,7 +48,12 @@ dist_libStdMeshersGUI_la_SOURCES = \
        StdMeshersGUI_DistrTable.cxx \
        StdMeshersGUI_NbSegmentsCreator.cxx \
        StdMeshersGUI_ObjectReferenceParamWdg.cxx \
-       StdMeshersGUI_LayerDistributionParamWdg.cxx
+       StdMeshersGUI_QuadrangleParamWdg.cxx \
+       StdMeshersGUI_LayerDistributionParamWdg.cxx \
+       StdMeshersGUI_FixedPointsParamWdg.cxx \
+       StdMeshersGUI_SubShapeSelectorWdg.cxx \
+       StdMeshersGUI_CartesianParamCreator.cxx \
+       StdMeshersGUI_RadioButtonsGrpWdg.cxx
 
 MOC_FILES = \
        StdMeshersGUI_StdHypothesisCreator_moc.cxx \
@@ -48,7 +61,12 @@ MOC_FILES = \
        StdMeshersGUI_DistrTable_moc.cxx \
        StdMeshersGUI_NbSegmentsCreator_moc.cxx \
        StdMeshersGUI_ObjectReferenceParamWdg_moc.cxx \
-       StdMeshersGUI_LayerDistributionParamWdg_moc.cxx
+       StdMeshersGUI_QuadrangleParamWdg_moc.cxx \
+       StdMeshersGUI_LayerDistributionParamWdg_moc.cxx \
+       StdMeshersGUI_FixedPointsParamWdg_moc.cxx \
+       StdMeshersGUI_SubShapeSelectorWdg_moc.cxx \
+       StdMeshersGUI_CartesianParamCreator_moc.cxx \
+       StdMeshersGUI_RadioButtonsGrpWdg_moc.cxx
 
 nodist_libStdMeshersGUI_la_SOURCES= \
        $(MOC_FILES)
@@ -68,6 +86,7 @@ libStdMeshersGUI_la_CPPFLAGS = \
        $(CORBA_CXXFLAGS) \
        $(CORBA_INCLUDES) \
        -I$(srcdir)/../SMESH \
+       -I$(srcdir)/../SMESHUtils \
        -I$(srcdir)/../SMESH_I \
        -I$(srcdir)/../SMESHDS \
        -I$(srcdir)/../SMDS \
@@ -76,9 +95,7 @@ libStdMeshersGUI_la_CPPFLAGS = \
        -I$(srcdir)/../StdMeshers \
        -I$(srcdir)/../OBJECT \
        -I$(srcdir)/../SMESHFiltersSelection \
-       -I$(top_builddir)/idl \
-       -I$(top_builddir)/salome_adm/unix
-
+       -I$(top_builddir)/idl
 
 libStdMeshersGUI_la_LDFLAGS  = \
        ../../idl/libSalomeIDLSMESH.la \
@@ -92,4 +109,6 @@ libStdMeshersGUI_la_LDFLAGS  = \
 # resources files
 nodist_salomeres_DATA= \
        StdMeshers_images.qm \
-       StdMeshers_msg_en.qm
+       StdMeshers_msg_en.qm \
+       StdMeshers_msg_fr.qm \
+       StdMeshers_msg_ja.qm