Salome HOME
Copyright update: 2016
[modules/smesh.git] / src / Tools / padder / meshjob / impl / CMakeLists.txt
index 19602bc56d66aba549f9e1e9ec8318776f48eb0b..28ab36e1145efb028c2bd6468966b9ac3d7d1b9f 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  EDF R&D
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -41,8 +41,13 @@ ADD_DEFINITIONS(
   ${CAS_DEFINITIONS}
   ${BOOST_DEFINITIONS}
   ${LIBXML2_DEFINITIONS}
+  ${OMNIORB_DEFINITIONS}
 )
 
+IF(WIN32)
+  ADD_DEFINITIONS(-DNOGDI)
+ENDIF(WIN32)
+
 # libraries to link to
 SET(MeshJobManagerEngine_LIBRARIES
   ${KERNEL_SalomeContainer}