Salome HOME
Update copyright notes (for 2010)
[modules/smesh.git] / src / StdMeshers_I / Makefile.am
index 9f908c722e2370bee2c03646251659b105942a0d..3331c0b368f61d1445a8e998f4cf97b73bd41d92 100644 (file)
@@ -1,31 +1,28 @@
-#  SMESH StdMeshers_I : idl implementation based on 'StdMeshersPlugin' unit's classes
+#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+#
+#  This library is free software; you can redistribute it and/or
+#  modify it under the terms of the GNU Lesser General Public
+#  License as published by the Free Software Foundation; either
+#  version 2.1 of the License.
 #
-#  Copyright (C) 2003  CEA
-# 
-#  This library is free software; you can redistribute it and/or 
-#  modify it under the terms of the GNU Lesser General Public 
-#  License as published by the Free Software Foundation; either 
-#  version 2.1 of the License. 
-# 
-#  This library is distributed in the hope that it will be useful, 
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
-#  Lesser General Public License for more details. 
-# 
-#  You should have received a copy of the GNU Lesser General Public 
-#  License along with this library; if not, write to the Free Software 
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
-# 
-# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+#  This library is distributed in the hope that it will be useful,
+#  but WITHOUT ANY WARRANTY; without even the implied warranty of
+#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+#  Lesser General Public License for more details.
 #
+#  You should have received a copy of the GNU Lesser General Public
+#  License along with this library; if not, write to the Free Software
+#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
+#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
+#  SMESH StdMeshers_I : idl implementation based on 'StdMeshersPlugin' unit's classes
 #  File   : Makefile.in
 #  Author : Julia DOROVSKIKH
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : SMESH
-#  $Header$
-
+#
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
@@ -33,6 +30,7 @@ salomeinclude_HEADERS = \
        StdMeshers_LocalLength_i.hxx \
        StdMeshers_StartEndLength_i.hxx \
        StdMeshers_Arithmetic1D_i.hxx \
+       StdMeshers_FixedPoints1D_i.hxx \
        StdMeshers_NumberOfSegments_i.hxx \
        StdMeshers_Deflection1D_i.hxx \
        StdMeshers_Propagation_i.hxx \
@@ -48,6 +46,7 @@ salomeinclude_HEADERS = \
        StdMeshers_QuadranglePreference_i.hxx \
        StdMeshers_QuadraticMesh_i.hxx \
        StdMeshers_NumberOfLayers_i.hxx \
+       StdMeshers_NumberOfLayers2D_i.hxx \
        StdMeshers_Prism_3D_i.hxx \
        StdMeshers_ProjectionSource1D_i.hxx \
        StdMeshers_ProjectionSource2D_i.hxx \
@@ -55,9 +54,15 @@ salomeinclude_HEADERS = \
        StdMeshers_Projection_1D_2D_3D_i.hxx \
        StdMeshers_ObjRefUlils.hxx \
        StdMeshers_LayerDistribution_i.hxx \
+       StdMeshers_LayerDistribution2D_i.hxx \
        StdMeshers_CompositeSegment_1D_i.hxx \
        StdMeshers_SegmentAroundVertex_0D_i.hxx \
        StdMeshers_SegmentLengthAroundVertex_i.hxx \
+       StdMeshers_UseExisting_1D2D_i.hxx \
+       StdMeshers_TrianglePreference_i.hxx \
+       StdMeshers_MaxLength_i.hxx \
+       StdMeshers_QuadrangleParams_i.hxx \
+       StdMeshers_RadialQuadrangle_1D2D_i.hxx \
        SMESH_StdMeshers_I.hxx
 
 # Libraries targets
@@ -68,6 +73,7 @@ dist_libStdMeshersEngine_la_SOURCES = \
         StdMeshers_LocalLength_i.cxx \
        StdMeshers_StartEndLength_i.cxx \
        StdMeshers_Arithmetic1D_i.cxx \
+       StdMeshers_FixedPoints1D_i.cxx \
        StdMeshers_NumberOfSegments_i.cxx \
        StdMeshers_Deflection1D_i.cxx \
         StdMeshers_Propagation_i.cxx \
@@ -83,6 +89,7 @@ dist_libStdMeshersEngine_la_SOURCES = \
        StdMeshers_QuadranglePreference_i.cxx \
        StdMeshers_QuadraticMesh_i.cxx \
        StdMeshers_NumberOfLayers_i.cxx \
+       StdMeshers_NumberOfLayers2D_i.cxx \
        StdMeshers_Prism_3D_i.cxx \
        StdMeshers_ProjectionSource1D_i.cxx \
        StdMeshers_ProjectionSource2D_i.cxx \
@@ -90,10 +97,15 @@ dist_libStdMeshersEngine_la_SOURCES = \
        StdMeshers_Projection_1D_2D_3D_i.cxx \
        StdMeshers_ObjRefUlils.cxx \
        StdMeshers_LayerDistribution_i.cxx \
+       StdMeshers_LayerDistribution2D_i.cxx \
        StdMeshers_CompositeSegment_1D_i.cxx \
        StdMeshers_SegmentAroundVertex_0D_i.cxx \
        StdMeshers_SegmentLengthAroundVertex_i.cxx \
-       StdMeshers_UseExisting_1D2D_i.cxx
+       StdMeshers_UseExisting_1D2D_i.cxx \
+       StdMeshers_TrianglePreference_i.cxx \
+       StdMeshers_MaxLength_i.cxx \
+       StdMeshers_QuadrangleParams_i.cxx \
+       StdMeshers_RadialQuadrangle_1D2D_i.cxx
 
 # additionnal information to compil and link file
 libStdMeshersEngine_la_CPPFLAGS = \
@@ -113,9 +125,7 @@ libStdMeshersEngine_la_CPPFLAGS = \
        -I$(srcdir)/../SMDS \
        -I$(srcdir)/../Controls \
        -I$(srcdir)/../StdMeshers \
-       -I$(top_builddir)/idl \
-       -I$(top_builddir)/salome_adm/unix
-
+       -I$(top_builddir)/idl
 
 libStdMeshersEngine_la_LDFLAGS  = \
        ../../idl/libSalomeIDLSMESH.la \