Salome HOME
Update copyright
[modules/smesh.git] / src / StdMeshers_I / Makefile.am
index 17d7c9f6fafbd543c9473629162f8cb6e81b1e2d..0ed513c5f894ff8c65fc900fc6b1912269544d9d 100644 (file)
@@ -1,20 +1,20 @@
-#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2011  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
 #  SMESH StdMeshers_I : idl implementation based on 'StdMeshersPlugin' unit's classes
@@ -67,7 +67,8 @@ salomeinclude_HEADERS = \
        StdMeshers_ImportSource1D_i.hxx \
        StdMeshers_ImportSource2D_i.hxx \
        StdMeshers_Import_1D_i.hxx \
-       StdMeshers_Import_1D2D_i.hxx
+       StdMeshers_Import_1D2D_i.hxx \
+       StdMeshers_ViscousLayers_i.hxx
 
 # Libraries targets
 lib_LTLIBRARIES = libStdMeshersEngine.la
@@ -113,7 +114,8 @@ dist_libStdMeshersEngine_la_SOURCES = \
        StdMeshers_ImportSource1D_i.cxx \
        StdMeshers_ImportSource2D_i.cxx \
        StdMeshers_Import_1D_i.cxx \
-       StdMeshers_Import_1D2D_i.cxx
+       StdMeshers_Import_1D2D_i.cxx \
+       StdMeshers_ViscousLayers_i.cxx
 
 # additionnal information to compil and link file
 libStdMeshersEngine_la_CPPFLAGS = \
@@ -123,6 +125,7 @@ libStdMeshersEngine_la_CPPFLAGS = \
        $(GEOM_CXXFLAGS) \
        $(MED_CXXFLAGS) \
        $(BOOST_CPPFLAGS) \
+        $(VTK_INCLUDES) \
        $(CORBA_CXXFLAGS) \
        $(CORBA_INCLUDES) \
        -I$(srcdir)/../SMESHImpl \