Salome HOME
Implementation of Quadrangle (Mapping) for faces built on 3 edges (0018911 from Mantis).
[modules/smesh.git] / src / StdMeshers_I / Makefile.am
index 9f908c722e2370bee2c03646251659b105942a0d..0238db8679edd2a647a39605a1df19e1bf294c96 100644 (file)
@@ -1,30 +1,29 @@
-#  SMESH StdMeshers_I : idl implementation based on 'StdMeshersPlugin' unit's classes
+#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+#
+#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
+#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
 #
-#  Copyright (C) 2003  CEA
-# 
-#  This library is free software; you can redistribute it and/or 
-#  modify it under the terms of the GNU Lesser General Public 
-#  License as published by the Free Software Foundation; either 
-#  version 2.1 of the License. 
-# 
-#  This library is distributed in the hope that it will be useful, 
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
-#  Lesser General Public License for more details. 
-# 
-#  You should have received a copy of the GNU Lesser General Public 
-#  License along with this library; if not, write to the Free Software 
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
-# 
-# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+#  This library is free software; you can redistribute it and/or
+#  modify it under the terms of the GNU Lesser General Public
+#  License as published by the Free Software Foundation; either
+#  version 2.1 of the License.
 #
+#  This library is distributed in the hope that it will be useful,
+#  but WITHOUT ANY WARRANTY; without even the implied warranty of
+#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+#  Lesser General Public License for more details.
 #
+#  You should have received a copy of the GNU Lesser General Public
+#  License along with this library; if not, write to the Free Software
+#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
+#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+#
+#  SMESH StdMeshers_I : idl implementation based on 'StdMeshersPlugin' unit's classes
 #  File   : Makefile.in
 #  Author : Julia DOROVSKIKH
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : SMESH
-#  $Header$
 
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
@@ -58,6 +57,10 @@ salomeinclude_HEADERS = \
        StdMeshers_CompositeSegment_1D_i.hxx \
        StdMeshers_SegmentAroundVertex_0D_i.hxx \
        StdMeshers_SegmentLengthAroundVertex_i.hxx \
+       StdMeshers_UseExisting_1D2D_i.hxx \
+       StdMeshers_TrianglePreference_i.hxx \
+       StdMeshers_MaxLength_i.hxx \
+       StdMeshers_QuadrangleParams_i.hxx \
        SMESH_StdMeshers_I.hxx
 
 # Libraries targets
@@ -93,7 +96,10 @@ dist_libStdMeshersEngine_la_SOURCES = \
        StdMeshers_CompositeSegment_1D_i.cxx \
        StdMeshers_SegmentAroundVertex_0D_i.cxx \
        StdMeshers_SegmentLengthAroundVertex_i.cxx \
-       StdMeshers_UseExisting_1D2D_i.cxx
+       StdMeshers_UseExisting_1D2D_i.cxx \
+       StdMeshers_TrianglePreference_i.cxx \
+       StdMeshers_MaxLength_i.cxx \
+       StdMeshers_QuadrangleParams_i.cxx
 
 # additionnal information to compil and link file
 libStdMeshersEngine_la_CPPFLAGS = \