Salome HOME
Merge from V6_main_20120808 08Aug12
[modules/smesh.git] / src / StdMeshersGUI / Makefile.am
index 38425ec0c078b36fa6e36d6cf46fd06c4a6f7fdc..3f7a1d8fff9db9dffc30092c248f8f1081685cd8 100644 (file)
@@ -1,30 +1,26 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
-#
-#  SMESH StdMeshersGUI : GUI for StdMeshers plugin
 #  File   : Makefile.in
 #  Author : Julia DOROVSKIKH
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : SMESH
-#
+
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
@@ -35,10 +31,15 @@ salomeinclude_HEADERS = \
        StdMeshersGUI_DistrTable.h \
        StdMeshersGUI_NbSegmentsCreator.h \
        StdMeshersGUI_ObjectReferenceParamWdg.h \
-       StdMeshersGUI_LayerDistributionParamWdg.h
+       StdMeshersGUI_QuadrangleParamWdg.h \
+       StdMeshersGUI_LayerDistributionParamWdg.h \
+       StdMeshersGUI_FixedPointsParamWdg.h \
+       StdMeshersGUI_SubShapeSelectorWdg.h \
+       StdMeshersGUI_CartesianParamCreator.h
 
 # Libraries targets
 lib_LTLIBRARIES = libStdMeshersGUI.la
+
 dist_libStdMeshersGUI_la_SOURCES = \
        StdMeshersGUI.cxx \
        StdMeshersGUI_StdHypothesisCreator.cxx \
@@ -46,7 +47,11 @@ dist_libStdMeshersGUI_la_SOURCES = \
        StdMeshersGUI_DistrTable.cxx \
        StdMeshersGUI_NbSegmentsCreator.cxx \
        StdMeshersGUI_ObjectReferenceParamWdg.cxx \
-       StdMeshersGUI_LayerDistributionParamWdg.cxx
+       StdMeshersGUI_QuadrangleParamWdg.cxx \
+       StdMeshersGUI_LayerDistributionParamWdg.cxx \
+       StdMeshersGUI_FixedPointsParamWdg.cxx \
+       StdMeshersGUI_SubShapeSelectorWdg.cxx \
+       StdMeshersGUI_CartesianParamCreator.cxx
 
 MOC_FILES = \
        StdMeshersGUI_StdHypothesisCreator_moc.cxx \
@@ -54,7 +59,11 @@ MOC_FILES = \
        StdMeshersGUI_DistrTable_moc.cxx \
        StdMeshersGUI_NbSegmentsCreator_moc.cxx \
        StdMeshersGUI_ObjectReferenceParamWdg_moc.cxx \
-       StdMeshersGUI_LayerDistributionParamWdg_moc.cxx
+       StdMeshersGUI_QuadrangleParamWdg_moc.cxx \
+       StdMeshersGUI_LayerDistributionParamWdg_moc.cxx \
+       StdMeshersGUI_FixedPointsParamWdg_moc.cxx \
+       StdMeshersGUI_SubShapeSelectorWdg_moc.cxx \
+       StdMeshersGUI_CartesianParamCreator_moc.cxx
 
 nodist_libStdMeshersGUI_la_SOURCES= \
        $(MOC_FILES)
@@ -74,6 +83,7 @@ libStdMeshersGUI_la_CPPFLAGS = \
        $(CORBA_CXXFLAGS) \
        $(CORBA_INCLUDES) \
        -I$(srcdir)/../SMESH \
+       -I$(srcdir)/../SMESHUtils \
        -I$(srcdir)/../SMESH_I \
        -I$(srcdir)/../SMESHDS \
        -I$(srcdir)/../SMDS \
@@ -82,9 +92,7 @@ libStdMeshersGUI_la_CPPFLAGS = \
        -I$(srcdir)/../StdMeshers \
        -I$(srcdir)/../OBJECT \
        -I$(srcdir)/../SMESHFiltersSelection \
-       -I$(top_builddir)/idl \
-       -I$(top_builddir)/salome_adm/unix
-
+       -I$(top_builddir)/idl
 
 libStdMeshersGUI_la_LDFLAGS  = \
        ../../idl/libSalomeIDLSMESH.la \
@@ -98,4 +106,5 @@ libStdMeshersGUI_la_LDFLAGS  = \
 # resources files
 nodist_salomeres_DATA= \
        StdMeshers_images.qm \
-       StdMeshers_msg_en.qm
+       StdMeshers_msg_en.qm \
+       StdMeshers_msg_fr.qm