Salome HOME
Copyright update: 2016
[modules/smesh.git] / src / StdMeshersGUI / CMakeLists.txt
index f01a226826a5eab945eb3c2c079da41b7535151d..f4beaf1aff652705606d7b77d3732123597152e2 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2015  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -72,7 +72,6 @@ SET(_link_LIBRARIES
 # header files / to be processed by moc
 SET(_moc_HEADERS
   StdMeshersGUI_StdHypothesisCreator.h
-  StdMeshersGUI_DistrPreview.h
   StdMeshersGUI_DistrTable.h
   StdMeshersGUI_NbSegmentsCreator.h
   StdMeshersGUI_ObjectReferenceParamWdg.h
@@ -82,8 +81,15 @@ SET(_moc_HEADERS
   StdMeshersGUI_SubShapeSelectorWdg.h
   StdMeshersGUI_CartesianParamCreator.h
   StdMeshersGUI_RadioButtonsGrpWdg.h
+  StdMeshersGUI_PropagationHelperWdg.h
 )
 
+IF(SALOME_USE_PLOT2DVIEWER)
+  LIST(APPEND _moc_HEADERS
+    StdMeshersGUI_DistrPreview.h
+    )
+ENDIF()
+
 # header files / no moc processing
 SET(_other_HEADERS
   SMESH_StdMeshersGUI.hxx
@@ -101,7 +107,6 @@ QT4_WRAP_CPP(_moc_SOURCES ${_moc_HEADERS})
 SET(_other_SOURCES
   StdMeshersGUI.cxx
   StdMeshersGUI_StdHypothesisCreator.cxx
-  StdMeshersGUI_DistrPreview.cxx
   StdMeshersGUI_DistrTable.cxx
   StdMeshersGUI_NbSegmentsCreator.cxx
   StdMeshersGUI_ObjectReferenceParamWdg.cxx
@@ -111,8 +116,15 @@ SET(_other_SOURCES
   StdMeshersGUI_SubShapeSelectorWdg.cxx
   StdMeshersGUI_CartesianParamCreator.cxx
   StdMeshersGUI_RadioButtonsGrpWdg.cxx
+  StdMeshersGUI_PropagationHelperWdg.cxx
 )
 
+IF(SALOME_USE_PLOT2DVIEWER)
+  LIST(APPEND _other_SOURCES
+    StdMeshersGUI_DistrPreview.cxx
+    )
+ENDIF()
+
 # sources / to compile
 SET(StdMeshersGUI_SOURCES ${_other_SOURCES} ${_moc_SOURCES})