Salome HOME
Regression of smesh/mesh_Projection_2D_01/B7
[modules/smesh.git] / src / StdMeshersGUI / CMakeLists.txt
index 2725c2443caa71ec81fa40009eeb116a26379309..be0c2a4dd6698d69992eb2173f4678febe78be9d 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2015  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -51,6 +51,7 @@ ADD_DEFINITIONS(
   ${CAS_DEFINITIONS}
   ${BOOST_DEFINITIONS}
   ${OMNIORB_DEFINITIONS}
+  ${QWT_DEFINITIONS}
 )
 
 # libraries to link to
@@ -59,6 +60,7 @@ SET(_link_LIBRARIES
   ${CAS_TKernel}
   ${CAS_TKBO}
   ${CAS_TKAdvTools}
+  ${QWT_LIBRARY}
   SalomeIDLSMESH
   SMESHFiltersSelection
   SMESH
@@ -80,6 +82,7 @@ SET(_moc_HEADERS
   StdMeshersGUI_SubShapeSelectorWdg.h
   StdMeshersGUI_CartesianParamCreator.h
   StdMeshersGUI_RadioButtonsGrpWdg.h
+  StdMeshersGUI_PropagationHelperWdg.h
 )
 
 # header files / no moc processing
@@ -109,6 +112,7 @@ SET(_other_SOURCES
   StdMeshersGUI_SubShapeSelectorWdg.cxx
   StdMeshersGUI_CartesianParamCreator.cxx
   StdMeshersGUI_RadioButtonsGrpWdg.cxx
+  StdMeshersGUI_PropagationHelperWdg.cxx
 )
 
 # sources / to compile