Salome HOME
Merge from V6_4_BR 05/12/2011
[modules/smesh.git] / src / StdMeshers / Makefile.am
index 0312e1f78cd0dbb8971dbefdd2c3fc8ad7b9115d..8f77a44996828c8f40971300be3c4bf30e7c8ae8 100644 (file)
@@ -1,20 +1,20 @@
-#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2011  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
 #  SMESH StdMeshers : implementaion of SMESH idl descriptions
@@ -67,12 +67,18 @@ salomeinclude_HEADERS = \
        StdMeshers_UseExisting_1D2D.hxx \
        StdMeshers_QuadToTriaAdaptor.hxx \
        SMESH_StdMeshers.hxx \
-       StdMeshers_TrianglePreference.hxx \
        StdMeshers_CompositeHexa_3D.hxx \
        StdMeshers_MaxLength.hxx \
        StdMeshers_QuadrangleParams.hxx \
        StdMeshers_RadialQuadrangle_1D2D.hxx \
-       StdMeshers_HexaFromSkin_3D.hxx
+       StdMeshers_HexaFromSkin_3D.hxx \
+       StdMeshers_ImportSource.hxx \
+       StdMeshers_Import_1D.hxx \
+       StdMeshers_Import_1D2D.hxx \
+       StdMeshers_ViscousLayers.hxx \
+       StdMeshers_Projection_1D2D.hxx \
+       StdMeshers_CartesianParameters3D.hxx \
+       StdMeshers_Cartesian_3D.hxx
 
 # Libraries targets
 
@@ -118,22 +124,28 @@ dist_libStdMeshers_la_SOURCES = \
        StdMeshers_CompositeSegment_1D.cxx \
        StdMeshers_UseExisting_1D2D.cxx \
        StdMeshers_QuadToTriaAdaptor.cxx \
-       StdMeshers_TrianglePreference.cxx \
        StdMeshers_CompositeHexa_3D.cxx \
        StdMeshers_MaxLength.cxx \
        StdMeshers_QuadrangleParams.cxx \
        StdMeshers_RadialQuadrangle_1D2D.cxx \
-       StdMeshers_HexaFromSkin_3D.cxx
-
+       StdMeshers_HexaFromSkin_3D.cxx \
+       StdMeshers_ImportSource.cxx \
+       StdMeshers_Import_1D.cxx \
+       StdMeshers_Import_1D2D.cxx \
+       StdMeshers_ViscousLayers.cxx \
+       StdMeshers_Projection_1D2D.cxx \
+       StdMeshers_CartesianParameters3D.cxx \
+       StdMeshers_Cartesian_3D.cxx
 
 # additionnal information to compil and link file
 libStdMeshers_la_CPPFLAGS = \
        $(CAS_CPPFLAGS) \
        $(BOOST_CPPFLAGS) \
+        $(VTK_INCLUDES) \
        $(KERNEL_CXXFLAGS) \
        $(GUI_CXXFLAGS) \
-       -I$(srcdir)/../SMESHImpl \
        -I$(srcdir)/../MEFISTO2 \
+       -I$(srcdir)/../SMESHUtils \
        -I$(srcdir)/../SMESH \
        -I$(srcdir)/../SMESHDS \
        -I$(srcdir)/../SMDS \
@@ -142,7 +154,6 @@ libStdMeshers_la_CPPFLAGS = \
 
 libStdMeshers_la_LDFLAGS  = \
        ../SMESH/libSMESHimpl.la \
-       ../SMESH_I/libSMESHEngine.la \
        ../SMESHDS/libSMESHDS.la \
        ../MEFISTO2/libMEFISTO2D.la \
        $(KERNEL_LDFLAGS) -lSALOMELocalTrace -lOpUtil \