Salome HOME
0021543: EDF 1978 SMESH: Viscous layer for 2D meshes
[modules/smesh.git] / src / StdMeshers / Makefile.am
index 08c312ead58d3e1f86cb6626e3b6cddc4a4d44a0..1739ddf8699de103e830bc240e503216593c7a53 100644 (file)
@@ -1,20 +1,20 @@
-#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
 #  SMESH StdMeshers : implementaion of SMESH idl descriptions
@@ -67,7 +67,6 @@ salomeinclude_HEADERS = \
        StdMeshers_UseExisting_1D2D.hxx \
        StdMeshers_QuadToTriaAdaptor.hxx \
        SMESH_StdMeshers.hxx \
-       StdMeshers_TrianglePreference.hxx \
        StdMeshers_CompositeHexa_3D.hxx \
        StdMeshers_MaxLength.hxx \
        StdMeshers_QuadrangleParams.hxx \
@@ -75,7 +74,12 @@ salomeinclude_HEADERS = \
        StdMeshers_HexaFromSkin_3D.hxx \
        StdMeshers_ImportSource.hxx \
        StdMeshers_Import_1D.hxx \
-       StdMeshers_Import_1D2D.hxx
+       StdMeshers_Import_1D2D.hxx \
+       StdMeshers_ViscousLayers.hxx \
+       StdMeshers_ViscousLayers2D.hxx \
+       StdMeshers_Projection_1D2D.hxx \
+       StdMeshers_CartesianParameters3D.hxx \
+       StdMeshers_Cartesian_3D.hxx
 
 # Libraries targets
 
@@ -121,7 +125,6 @@ dist_libStdMeshers_la_SOURCES = \
        StdMeshers_CompositeSegment_1D.cxx \
        StdMeshers_UseExisting_1D2D.cxx \
        StdMeshers_QuadToTriaAdaptor.cxx \
-       StdMeshers_TrianglePreference.cxx \
        StdMeshers_CompositeHexa_3D.cxx \
        StdMeshers_MaxLength.cxx \
        StdMeshers_QuadrangleParams.cxx \
@@ -129,17 +132,22 @@ dist_libStdMeshers_la_SOURCES = \
        StdMeshers_HexaFromSkin_3D.cxx \
        StdMeshers_ImportSource.cxx \
        StdMeshers_Import_1D.cxx \
-       StdMeshers_Import_1D2D.cxx
-
+       StdMeshers_Import_1D2D.cxx \
+       StdMeshers_ViscousLayers.cxx \
+       StdMeshers_ViscousLayers2D.cxx \
+       StdMeshers_Projection_1D2D.cxx \
+       StdMeshers_CartesianParameters3D.cxx \
+       StdMeshers_Cartesian_3D.cxx
 
 # additionnal information to compil and link file
 libStdMeshers_la_CPPFLAGS = \
        $(CAS_CPPFLAGS) \
        $(BOOST_CPPFLAGS) \
+        $(VTK_INCLUDES) \
        $(KERNEL_CXXFLAGS) \
        $(GUI_CXXFLAGS) \
-       -I$(srcdir)/../SMESHImpl \
        -I$(srcdir)/../MEFISTO2 \
+       -I$(srcdir)/../SMESHUtils \
        -I$(srcdir)/../SMESH \
        -I$(srcdir)/../SMESHDS \
        -I$(srcdir)/../SMDS \
@@ -148,8 +156,12 @@ libStdMeshers_la_CPPFLAGS = \
 
 libStdMeshers_la_LDFLAGS  = \
        ../SMESH/libSMESHimpl.la \
-       ../SMESH_I/libSMESHEngine.la \
        ../SMESHDS/libSMESHDS.la \
        ../MEFISTO2/libMEFISTO2D.la \
        $(KERNEL_LDFLAGS) -lSALOMELocalTrace -lOpUtil \
        $(CAS_LDPATH) -lTKAdvTools -lTKTopAlgo -lTKG3d
+
+if WITH_TBB
+  libStdMeshers_la_CPPFLAGS += $(TBB_INCLUDES)
+  libStdMeshers_la_LDFLAGS  += $(TBB_LIBS)
+endif