Salome HOME
bos #24257 [CEA] Fatal error when creating a submesh if the mesh is on a sub-shape
[modules/smesh.git] / src / StdMeshers / CMakeLists.txt
index 87e4db8ebcc8929e4e19d5af901ca0f23e1bdcd6..0a69940c1474d982c49f0d6e0da50f035327d83c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2020  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2021  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -64,6 +64,7 @@ SET(_link_LIBRARIES
   SMESHDS
   SMESHUtils
   ${TBB_LIBS}
+  ${Boost_LIBRARIES}
 )
 
 IF(SALOME_SMESH_ENABLE_MEFISTO)
@@ -131,6 +132,7 @@ SET(StdMeshers_HEADERS
   StdMeshers_QuadFromMedialAxis_1D2D.hxx
   StdMeshers_PolygonPerFace_2D.hxx
   StdMeshers_PolyhedronPerSolid_3D.hxx
+  StdMeshers_BlockRenumber.hxx
 )
 
 IF(SALOME_SMESH_ENABLE_MEFISTO)
@@ -197,6 +199,7 @@ SET(StdMeshers_SOURCES
   StdMeshers_QuadFromMedialAxis_1D2D.cxx
   StdMeshers_PolygonPerFace_2D.cxx
   StdMeshers_PolyhedronPerSolid_3D.cxx
+  StdMeshers_BlockRenumber.cxx
 )
 
 IF(SALOME_SMESH_ENABLE_MEFISTO)