Salome HOME
Merge from V6_3_BR 06/06/2011
[modules/smesh.git] / src / SMESH_SWIG_WITHIHM / Makefile.am
index 7988a23ea2405d464fa653b7bf8138e31ea3296f..525f09239bbf1b46b8a7c19f642424dacb24898d 100644 (file)
@@ -1,30 +1,26 @@
-#  Copyright (C) 2003  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS 
-# 
-#  This library is free software; you can redistribute it and/or 
-#  modify it under the terms of the GNU Lesser General Public 
-#  License as published by the Free Software Foundation; either 
-#  version 2.1 of the License. 
-# 
-#  This library is distributed in the hope that it will be useful, 
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
-#  Lesser General Public License for more details. 
-# 
-#  You should have received a copy of the GNU Lesser General Public 
-#  License along with this library; if not, write to the Free Software 
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
-# 
-# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# Copyright (C) 2007-2011  CEA/DEN, EDF R&D, OPEN CASCADE
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
-#  File   : Makefile.in
-#  Author : Nicolas REJNERI, Paul RASCLE
-#  Modified by : Alexander BORODIN (OCN) - autotools usage
-#  Module : SMESH
-#  $Header$
 
+# SMESH SMESHGUI : GUI for SMESH component
+# File   : Makefile.am
+# Author : Alexander BORODIN, Open CASCADE S.A.S.
+#
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # ===============================================================
@@ -40,76 +36,64 @@ include $(top_srcdir)/adm_local/unix/make_common_starter.am
 # Step 2: build the dynamic library from cpp built source files and
 #         dependant libraries.
 #
-# swig_wrap.cpp -- gcc --> swig_wrap.o    |-- link --> _libSALOME_Swig.la
+# swig_wrap.cpp -- gcc --> swig_wrap.o    |-- link --> _libSMESH_Swig.la
 #                          +              |
 #                          dependant libs |
 #
-# The file libSALOME_Swigcmodule.py will be installed in
-# <prefix>/lib/python<version>/site-package/salome.
-# The library will be installed in the same place.
+# The file libSMESH_Swig.py will be installed to the
+# <prefix>/bin/salome directory.
+# The library _libSMESH_Swig.so will be installed to the 
+# <prefix>/lib/python<version>/site-package/salome directory.
 #
 
-# this option puts it to dist
-#BUILT_SOURCES = swig_wrap.cpp
-
-SWIG_FLAGS    = \
-       @SWIG_FLAGS@ \
-       -I$(srcdir) \
-       -I$(srcdir)/../SMESHGUI
-
+SWIG_FLAGS    = @SWIG_FLAGS@ -I$(srcdir) -I$(srcdir)/../SMESHGUI
 SWIG_SOURCES  = libSMESH_Swig.i
 
-# Libraries targets
-
-lib_LTLIBRARIES = libSMESH_Swigcmodule.la
-
-nodist_pkgpython_DATA = libSMESH_Swig.py
-libSMESH_Swig.py: swig_wrap.cpp
-
-libSMESH_Swigcmodule_la_SOURCES = \
-       $(BUILT_SOURCES) \
-       $(SWIG_SOURCES) \
-       ../SMESHGUI/SMESHGUI_Swig.cxx
-
-nodist_libSMESH_Swigcmodule_la_SOURCES = \
-       swig_wrap.cpp
-
-libSMESH_Swigcmodule_la_CPPFLAGS = \
-       $(QT_INCLUDES) \
-       $(PYTHON_INCLUDES) \
-       $(CAS_CPPFLAGS) \
-       $(VTK_INCLUDES) \
-       $(OGL_INCLUDES) \
-       $(KERNEL_CXXFLAGS) \
-       $(GUI_CXXFLAGS) \
-       $(MED_CXXFLAGS) \
-       $(GEOM_CXXFLAGS) \
-       $(CORBA_CXXFLAGS) \
-       $(CORBA_INCLUDES) \
-       $(BOOST_CPPFLAGS) \
-       -I$(srcdir)/../SMESHGUI \
-       -I$(top_builddir)/idl \
-       -I$(top_builddir)/salome_adm/unix
-
-libSMESH_Swigcmodule_la_LDFLAGS  = \
-       ../SMESHGUI/libSMESH.la \
-       $(KERNEL_LDFLAGS) -lSalomeGenericObj -lSALOMELocalTrace \
-       $(GUI_LDFLAGS) -lCAM -lsuit -lqtx -lSalomeApp -lstd -lEvent \
-       $(PYTHON_LIBS) \
-       $(QT_MT_LIBS)
+salomeinclude_HEADERS = $(SWIG_SOURCES) libSMESH_Swig.h
 
+# Libraries targets
+lib_LTLIBRARIES                  = _libSMESH_Swig.la
+_libSMESH_Swig_la_SOURCES        = $(SWIG_SOURCES) libSMESH_Swig.h libSMESH_Swig.cxx
+nodist__libSMESH_Swig_la_SOURCES = swig_wrap.cpp
+
+_libSMESH_Swig_la_CPPFLAGS =   \
+       $(QT_INCLUDES)          \
+       $(PYTHON_INCLUDES)      \
+       $(CAS_CPPFLAGS)         \
+       $(VTK_INCLUDES)         \
+       $(OGL_INCLUDES)         \
+       $(KERNEL_CXXFLAGS)      \
+       $(GUI_CXXFLAGS)         \
+       $(MED_CXXFLAGS)         \
+       $(GEOM_CXXFLAGS)        \
+       $(CORBA_CXXFLAGS)       \
+       $(CORBA_INCLUDES)       \
+       $(BOOST_CPPFLAGS)       \
+       -I$(srcdir)             \
+       -I$(srcdir)/../SMESHGUI \
+       -I$(top_builddir)/idl
+
+_libSMESH_Swig_la_LDFLAGS  = -module
+_libSMESH_Swig_la_LIBADD   = ../SMESHGUI/libSMESH.la                   \
+       $(KERNEL_LDFLAGS) -lSalomeGenericObj -lSALOMELocalTrace         \
+       $(GUI_LDFLAGS) -lCAM -lsuit -lqtx -lSalomeApp -lstd -lEvent     \
+       $(PYTHON_LIBS) $(QT_MT_LIBS)
 
 swig_wrap.cpp : $(SWIG_SOURCES)
        $(SWIG) $(SWIG_FLAGS) -o $@ $<
 
-CLEANFILES = \
-       swig_wrap.cpp
+libSMESH_Swig.py: swig_wrap.cpp
 
-# Scripts to be installed.
-dist_salomescript_DATA= \
-       libSMESH_Swig.py
+CLEANFILES = swig_wrap.cpp libSMESH_Swig.py
+
+#
+# ===============================================================
+# Files to be installed
+# ===============================================================
+#
 
-install-exec-hook: $(libdir)/_libSMESH_Swig.so
+# Scripts to be installed (distributed)
+dist_salomescript_DATA =
 
-$(libdir)/_libSMESH_Swig.so:
-       ( cd $(libdir); ln -sf libSMESH_Swigcmodule.so _libSMESH_Swig.so; )
+# Scripts to be installed (non-distributed)
+nodist_salomescript_DATA = libSMESH_Swig.py