Salome HOME
SALOME Forum bug: sub-mesh removal leads to an Exception in a re-opened study.
[modules/smesh.git] / src / SMESH_I / Makefile.am
index 4f05fa7a4ee6baf0d81f08dfa129f4607a6aea4d..e5ddeed579561f4451ddd8b2667029529624452f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2013  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -38,11 +38,8 @@ salomeinclude_HEADERS = \
        SMESH_Hypothesis_i.hxx \
        SMESH_PythonDump.hxx \
        SMESH_Group_i.hxx \
-       SMESH_MEDMesh_i.hxx \
        SMESH_Filter_i.hxx \
        SMESH_MeshEditor_i.hxx \
-       SMESH_MEDFamily_i.hxx \
-       SMESH_MEDSupport_i.hxx \
        SMESH_Pattern_i.hxx \
        SMESH_2smeshpy.hxx \
        SMESH_NoteBook.hxx \
@@ -51,10 +48,6 @@ salomeinclude_HEADERS = \
        SMESH_MeshPartDS.hxx \
        SMESH.hxx
 
-# Scripts to be installed.
-dist_salomescript_DATA= \
-       smeshpy.py
-
 # Libraries targets
 
 lib_LTLIBRARIES = libSMESHEngine.la
@@ -64,9 +57,6 @@ dist_libSMESHEngine_la_SOURCES = \
        SMESH_Gen_i_1.cxx \
        SMESH_DumpPython.cxx \
        SMESH_Mesh_i.cxx \
-       SMESH_MEDMesh_i.cxx \
-       SMESH_MEDFamily_i.cxx \
-       SMESH_MEDSupport_i.cxx \
        SMESH_subMesh_i.cxx \
        SMESH_MeshEditor_i.cxx \
        SMESH_Hypothesis_i.cxx \
@@ -99,17 +89,19 @@ libSMESHEngine_la_CPPFLAGS = \
        $(BOOST_CPPFLAGS) \
        $(KERNEL_CXXFLAGS) \
        $(GUI_CXXFLAGS) \
-       $(MED_CXXFLAGS) \
        $(GEOM_CXXFLAGS) \
        -I$(srcdir)/../Controls \
        -I$(srcdir)/../SMDS \
        -I$(srcdir)/../SMESHDS \
+       -I$(srcdir)/../MEDWrapper/Base \
+       -I$(srcdir)/../MEDWrapper/Factory \
        -I$(srcdir)/../Driver \
        -I$(srcdir)/../DriverMED \
        -I$(srcdir)/../DriverCGNS \
        -I$(srcdir)/../SMESH \
        -I$(srcdir)/../SMESHUtils \
-       -I$(top_builddir)/idl
+       -I$(top_builddir)/idl \
+       -I$(top_builddir)
 
 libSMESHEngine_la_LDFLAGS  = \
        ../../idl/libSalomeIDLSMESH.la \
@@ -118,6 +110,11 @@ libSMESHEngine_la_LDFLAGS  = \
        ../SMESHDS/libSMESHDS.la \
        ../Controls/libSMESHControls.la \
        $(KERNEL_LDFLAGS) \
+       -lOpUtil \
+       -lSalomeNotification \
+       -lResourcesManager \
+       -lSalomeResourcesManager \
+       -lSALOMEBasics \
        -lSalomeContainer \
        -lSalomeNS \
        -lRegistry \
@@ -127,10 +124,6 @@ libSMESHEngine_la_LDFLAGS  = \
        -lSalomeGenericObj \
        -lSalomeIDLKernel \
        -lSALOMELocalTrace \
-       $(MED_LDFLAGS) \
-       -lMEDWrapper \
-       -lMEDWrapper_V2_2 \
-        -lSalomeIDLMED \
        $(CAS_LDPATH) \
        -lTKCDF \
        -lTKBO \