Salome HOME
SALOME Forum bug: sub-mesh removal leads to an Exception in a re-opened study.
[modules/smesh.git] / src / SMESH_I / Makefile.am
index 2a15a44df935ab6b5d9607c143783dd28a744204..e5ddeed579561f4451ddd8b2667029529624452f 100644 (file)
@@ -1,24 +1,22 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2013  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 #  SMESH SMESH_I : idl implementation based on 'SMESH' unit's calsses
 #  File   : Makefile.in
 #  Author : Paul RASCLE, EDF
@@ -40,20 +38,16 @@ salomeinclude_HEADERS = \
        SMESH_Hypothesis_i.hxx \
        SMESH_PythonDump.hxx \
        SMESH_Group_i.hxx \
-       SMESH_MEDMesh_i.hxx \
        SMESH_Filter_i.hxx \
        SMESH_MeshEditor_i.hxx \
-       SMESH_MEDFamily_i.hxx \
-       SMESH_MEDSupport_i.hxx \
        SMESH_Pattern_i.hxx \
        SMESH_2smeshpy.hxx \
        SMESH_NoteBook.hxx \
+       SMESH_Measurements_i.hxx \
+       SMESH_PreMeshInfo.hxx \
+       SMESH_MeshPartDS.hxx \
        SMESH.hxx
 
-# Scripts to be installed.
-dist_salomescript_DATA= \
-       smeshpy.py
-
 # Libraries targets
 
 lib_LTLIBRARIES = libSMESHEngine.la
@@ -63,9 +57,6 @@ dist_libSMESHEngine_la_SOURCES = \
        SMESH_Gen_i_1.cxx \
        SMESH_DumpPython.cxx \
        SMESH_Mesh_i.cxx \
-       SMESH_MEDMesh_i.cxx \
-       SMESH_MEDFamily_i.cxx \
-       SMESH_MEDSupport_i.cxx \
        SMESH_subMesh_i.cxx \
        SMESH_MeshEditor_i.cxx \
        SMESH_Hypothesis_i.cxx \
@@ -78,7 +69,9 @@ dist_libSMESHEngine_la_SOURCES = \
        SMESH_Group_i.cxx \
        SMESH_Pattern_i.cxx \
        SMESH_2smeshpy.cxx \
-       SMESH_NoteBook.cxx 
+       SMESH_NoteBook.cxx \
+       SMESH_Measurements_i.cxx \
+       SMESH_PreMeshInfo.cxx
 
 # Executables targets
 bin_PROGRAMS = SMESHEngine
@@ -92,26 +85,36 @@ libSMESHEngine_la_CPPFLAGS = \
        $(CORBA_INCLUDES) \
        $(CAS_CPPFLAGS) \
        @HDF5_INCLUDES@ \
+        $(VTK_INCLUDES) \
        $(BOOST_CPPFLAGS) \
        $(KERNEL_CXXFLAGS) \
        $(GUI_CXXFLAGS) \
-       $(MED_CXXFLAGS) \
        $(GEOM_CXXFLAGS) \
        -I$(srcdir)/../Controls \
        -I$(srcdir)/../SMDS \
        -I$(srcdir)/../SMESHDS \
+       -I$(srcdir)/../MEDWrapper/Base \
+       -I$(srcdir)/../MEDWrapper/Factory \
        -I$(srcdir)/../Driver \
        -I$(srcdir)/../DriverMED \
+       -I$(srcdir)/../DriverCGNS \
        -I$(srcdir)/../SMESH \
+       -I$(srcdir)/../SMESHUtils \
        -I$(top_builddir)/idl \
-       -I$(top_builddir)/salome_adm/unix
-
+       -I$(top_builddir)
 
 libSMESHEngine_la_LDFLAGS  = \
        ../../idl/libSalomeIDLSMESH.la \
        ../SMESH/libSMESHimpl.la \
+       ../SMDS/libSMDS.la \
+       ../SMESHDS/libSMESHDS.la \
        ../Controls/libSMESHControls.la \
        $(KERNEL_LDFLAGS) \
+       -lOpUtil \
+       -lSalomeNotification \
+       -lResourcesManager \
+       -lSalomeResourcesManager \
+       -lSALOMEBasics \
        -lSalomeContainer \
        -lSalomeNS \
        -lRegistry \
@@ -119,15 +122,15 @@ libSMESHEngine_la_LDFLAGS  = \
        -lSalomeLifeCycleCORBA \
        -lTOOLSDS \
        -lSalomeGenericObj \
-       $(MED_LDFLAGS) \
-       -lMEDWrapper_V2_2 \
-        -lSalomeIDLMED \
+       -lSalomeIDLKernel \
+       -lSALOMELocalTrace \
        $(CAS_LDPATH) \
        -lTKCDF \
        -lTKBO \
        -lTKShHealing \
        $(GEOM_LDFLAGS) \
-       -lGEOMClient
+       -lGEOMClient \
+       -lSalomeIDLGEOM
 
 SMESHEngine_CPPFLAGS = \
        $(libSMESHEngine_la_CPPFLAGS)