Salome HOME
PR: distributed geom and smesh scripts: first step
[modules/smesh.git] / src / SMESH_I / Makefile.am
index 5544de5af5eb918857f58240ecb355b6f157cd44..39bcea103fa473f1fd271483598d211c1413a166 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2007-2011  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -47,11 +47,13 @@ salomeinclude_HEADERS = \
        SMESH_2smeshpy.hxx \
        SMESH_NoteBook.hxx \
        SMESH_Measurements_i.hxx \
+       SMESH_PreMeshInfo.hxx \
+       SMESH_MeshPartDS.hxx \
        SMESH.hxx
 
 # Scripts to be installed.
-dist_salomescript_DATA= \
-       smeshpy.py
+#dist_salomescript_DATA= \
+#      smeshpy.py
 
 # Libraries targets
 
@@ -78,7 +80,8 @@ dist_libSMESHEngine_la_SOURCES = \
        SMESH_Pattern_i.cxx \
        SMESH_2smeshpy.cxx \
        SMESH_NoteBook.cxx \
-       SMESH_Measurements_i.cxx
+       SMESH_Measurements_i.cxx \
+       SMESH_PreMeshInfo.cxx
 
 # Executables targets
 bin_PROGRAMS = SMESHEngine
@@ -103,8 +106,11 @@ libSMESHEngine_la_CPPFLAGS = \
        -I$(srcdir)/../SMESHDS \
        -I$(srcdir)/../Driver \
        -I$(srcdir)/../DriverMED \
+       -I$(srcdir)/../DriverCGNS \
        -I$(srcdir)/../SMESH \
-       -I$(top_builddir)/idl
+       -I$(srcdir)/../SMESHUtils \
+       -I$(top_builddir)/idl \
+       -I$(top_builddir)
 
 libSMESHEngine_la_LDFLAGS  = \
        ../../idl/libSalomeIDLSMESH.la \