Salome HOME
#23999 EDF 22760 - integration of dev in SMESH (from branch 'gni/adaptation')
[modules/smesh.git] / src / SMESH_I / CMakeLists.txt
index a68453fc461b75da4183ac13ecb64352843ead6e..b9df761dd2f511c7492e19606d7c740c939a8b80 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2019  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2020  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -31,6 +31,7 @@ INCLUDE_DIRECTORIES(
   ${PROJECT_SOURCE_DIR}/src/Controls
   ${PROJECT_SOURCE_DIR}/src/SMDS
   ${PROJECT_SOURCE_DIR}/src/SMESHDS
+  ${PROJECT_SOURCE_DIR}/src/SMESH_I
   ${PROJECT_SOURCE_DIR}/src/MEDWrapper
   ${PROJECT_SOURCE_DIR}/src/Driver
   ${PROJECT_SOURCE_DIR}/src/DriverMED
@@ -39,6 +40,7 @@ INCLUDE_DIRECTORIES(
   ${PROJECT_SOURCE_DIR}/src/SMESHUtils
   ${PROJECT_BINARY_DIR}
   ${PROJECT_BINARY_DIR}/idl
+  ${MEDCOUPLING_INCLUDE_DIRS}
 )
 
 # additional preprocessor / compiler flags
@@ -70,6 +72,8 @@ SET(_link_LIBRARIES
   ${KERNEL_SalomeIDLKERNEL}
   ${KERNEL_SALOMELocalTrace}
   ${KERNEL_SalomeKernelHelpers}
+  ${KERNEL_SalomeDS}
+  ${KERNEL_SalomeCatalog}
   ${OpenCASCADE_ApplicationFramework_LIBRARIES}
   ${OpenCASCADE_ModelingAlgorithms_LIBRARIES}
   ${GEOM_GEOMClient}
@@ -81,6 +85,7 @@ SET(_link_LIBRARIES
   SMESHDS
   SMESHControls
   MeshDriverMED
+  ${MEDCoupling_medloader}
 )
 
 # --- headers ---
@@ -88,6 +93,8 @@ SET(_link_LIBRARIES
 # header files / no moc processing
 SET(SMESHEngine_HEADERS
   SMESH_Gen_i.hxx
+  SMESH_Gen_No_Session_i.hxx
+  SMESH_Gen_Session_i.hxx
   SMESH_Algo_i.hxx
   SMESH_0D_Algo_i.hxx
   SMESH_1D_Algo_i.hxx
@@ -107,6 +114,8 @@ SET(SMESHEngine_HEADERS
   SMESH_PreMeshInfo.hxx
   SMESH_MeshPartDS.hxx
   SMESH.hxx
+  SMESH_Component_Generator.hxx
+  MG_ADAPT_i.hxx
 )
 
 # --- sources ---
@@ -115,6 +124,8 @@ SET(SMESHEngine_HEADERS
 SET(SMESHEngine_SOURCES
   SMESH_Gen_i.cxx
   SMESH_Gen_i_1.cxx
+  SMESH_Gen_No_Session_i.cxx
+  SMESH_Gen_Session_i.cxx
   SMESH_PythonDump.cxx
   SMESH_Mesh_i.cxx
   SMESH_subMesh_i.cxx
@@ -132,6 +143,8 @@ SET(SMESHEngine_SOURCES
   SMESH_NoteBook.cxx
   SMESH_Measurements_i.cxx
   SMESH_PreMeshInfo.cxx
+  SMESH_Component_Generator.cxx
+  MG_ADAPT_i.cxx
 )
 
 # --- rules ---