Salome HOME
Merge branch 'V8_4_BR'
[modules/smesh.git] / src / SMESH_I / CMakeLists.txt
index 0fc7efbace5d282e8a54d3d587a6a56903e84f76..8be022d98111b985d975528e72c0c9e7bd551188 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -21,7 +21,7 @@
 # additional include directories
 INCLUDE_DIRECTORIES(
   ${OMNIORB_INCLUDE_DIR}
-  ${CAS_INCLUDE_DIRS}
+  ${OpenCASCADE_INCLUDE_DIR}
   ${HDF5_INCLUDE_DIRS}
   ${VTK_INCLUDE_DIRS}
   ${Boost_INCLUDE_DIRS}
@@ -45,10 +45,14 @@ INCLUDE_DIRECTORIES(
 # additional preprocessor / compiler flags
 ADD_DEFINITIONS(
   ${OMNIORB_DEFINITIONS}
-  ${CAS_DEFINITIONS}
+  ${OpenCASCADE_DEFINITIONS}
   ${BOOST_DEFINITIONS}
 )
 
+IF(WIN32)
+  ADD_DEFINITIONS(-DNOGDI)
+ENDIF(WIN32)
+
 # libraries to link to
 SET(_link_LIBRARIES
   ${Boost_LIBRARIES}
@@ -66,16 +70,16 @@ SET(_link_LIBRARIES
   ${KERNEL_SalomeGenericObj}
   ${KERNEL_SalomeIDLKERNEL}
   ${KERNEL_SALOMELocalTrace}
-  ${CAS_TKCDF}
-  ${CAS_TKBO}
-  ${CAS_TKShHealing}
+  ${OpenCASCADE_ApplicationFramework_LIBRARIES}
+  ${OpenCASCADE_ModelingAlgorithms_LIBRARIES}
   ${GEOM_GEOMClient}
-  ${GEOM_SalomeIDLGEOM}  
+  ${GEOM_SalomeIDLGEOM}
   SalomeIDLSMESH
   SMESHimpl
   SMDS
   SMESHDS
   SMESHControls
+  MeshDriverMED
 )
 
 # --- headers ---
@@ -129,20 +133,10 @@ SET(SMESHEngine_SOURCES
   SMESH_PreMeshInfo.cxx
 )
 
-# bin programs
-SET(SMESHEngine_bin_SOURCES
-  SMESHEngine.cxx 
-)
-
 # --- rules ---
 
 ADD_LIBRARY(SMESHEngine ${SMESHEngine_SOURCES})
 TARGET_LINK_LIBRARIES(SMESHEngine ${_link_LIBRARIES} )
 INSTALL(TARGETS SMESHEngine EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 
-ADD_EXECUTABLE(SMESHEngine_bin ${SMESHEngine_bin_SOURCES})
-TARGET_LINK_LIBRARIES(SMESHEngine_bin ${_link_LIBRARIES})
-SET_TARGET_PROPERTIES(SMESHEngine_bin PROPERTIES OUTPUT_NAME "SMESHEngine")
-INSTALL(TARGETS SMESHEngine_bin EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_BINS})
-
 INSTALL(FILES ${SMESHEngine_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})