Salome HOME
Copyright update 2020
[modules/smesh.git] / src / SMESHUtils / CMakeLists.txt
index 5261c5d7fdebc35f3684644b26186d9f6a66e4df..d337f121f68b034cf2a9b6c34f048c7e3ff14d24 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2014  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2020  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # additional include directories
 INCLUDE_DIRECTORIES(
   ${KERNEL_INCLUDE_DIRS}
-  ${CAS_INCLUDE_DIRS}
-  ${VTK_INCLUDE_DIRS}
+  ${OpenCASCADE_INCLUDE_DIR}
   ${Boost_INCLUDE_DIRS}
   ${PROJECT_SOURCE_DIR}/src/SMDS
-  ${PROJECT_SOURCE_DIR}/src/SMESHDS
 )
 
 # additional preprocessor / compiler flags
 ADD_DEFINITIONS(
-  ${CAS_DEFINITIONS}
+  ${OpenCASCADE_DEFINITIONS}
   ${BOOST_DEFINITIONS}
 )
 
 # libraries to link to
 SET(_link_LIBRARIES
-  ${CAS_TKShHealing}
-  ${CAS_TKPrim}
-  ${CAS_TKG2d}
-  ${CAS_TKG3d}
-  ${CAS_TKGeomBase}
-  ${CAS_TKGeomAlgo}
-  ${Boost_LIBRARIES}
-  SMESHDS
+   ${OpenCASCADE_ModelingAlgorithms_LIBRARIES}
+   ${OpenCASCADE_FoundationClasses_LIBRARIES}
+   ${OpenCASCADE_ModelingData_LIBRARIES}
+   ${Boost_LIBRARIES}
+   SMDS
 )
 
 # --- headers ---
@@ -62,7 +57,11 @@ SET(SMESHUtils_HEADERS
   SMESH_Utils.hxx
   SMESH_TryCatch.hxx
   SMESH_MeshAlgos.hxx
-)
+  SMESH_MAT2d.hxx
+  SMESH_ControlPnt.hxx
+  SMESH_Delaunay.hxx
+  SMESH_Indexer.hxx
+  )
 
 # --- sources ---
 
@@ -75,7 +74,17 @@ SET(SMESHUtils_SOURCES
   SMESH_TryCatch.cxx
   SMESH_File.cxx
   SMESH_MeshAlgos.cxx
-)
+  SMESH_MAT2d.cxx
+  SMESH_FreeBorders.cxx
+  SMESH_ControlPnt.cxx
+  SMESH_DeMerge.cxx
+  SMESH_Delaunay.cxx
+  SMESH_FillHole.cxx
+  SMESH_Triangulate.cxx
+  SMESH_Offset.cxx
+  SMESH_Slot.cxx
+  SMESH_PolyLine.cxx
+  )
 
 # --- rules ---