Salome HOME
23627: [IMACS] ASERIS: project point to the mesh and create a slot
[modules/smesh.git] / src / SMESHUtils / CMakeLists.txt
index 8bafe47f4e7ec1808a0ab9bf40b510faf15e0a52..d1f527b1db3f3efa7979c595ab636a615bd6276f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2015  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -21,7 +21,7 @@
 # additional include directories
 INCLUDE_DIRECTORIES(
   ${KERNEL_INCLUDE_DIRS}
-  ${CAS_INCLUDE_DIRS}
+  ${OpenCASCADE_INCLUDE_DIR}
   ${VTK_INCLUDE_DIRS}
   ${Boost_INCLUDE_DIRS}
   ${PROJECT_SOURCE_DIR}/src/SMDS
@@ -29,23 +29,17 @@ INCLUDE_DIRECTORIES(
 
 # additional preprocessor / compiler flags
 ADD_DEFINITIONS(
-  ${CAS_DEFINITIONS}
+  ${OpenCASCADE_DEFINITIONS}
   ${BOOST_DEFINITIONS}
 )
 
 # libraries to link to
 SET(_link_LIBRARIES
-  ${CAS_TKShHealing}
-  ${CAS_TKPrim}
-  ${CAS_TKernel}
-  ${CAS_TKBRep}
-  ${CAS_TKG2d}
-  ${CAS_TKG3d}
-  ${CAS_TKGeomBase}
-  ${CAS_TKGeomAlgo}
-  ${CAS_TKTopAlgo}
-  ${Boost_LIBRARIES}
-  SMDS
+   ${OpenCASCADE_ModelingAlgorithms_LIBRARIES}
+   ${OpenCASCADE_FoundationClasses_LIBRARIES}
+   ${OpenCASCADE_ModelingData_LIBRARIES}
+   ${Boost_LIBRARIES}
+   SMDS
 )
 
 # --- headers ---
@@ -65,7 +59,9 @@ SET(SMESHUtils_HEADERS
   SMESH_TryCatch.hxx
   SMESH_MeshAlgos.hxx
   SMESH_MAT2d.hxx
-)
+  SMESH_ControlPnt.hxx
+  SMESH_Delaunay.hxx
+  )
 
 # --- sources ---
 
@@ -79,7 +75,16 @@ SET(SMESHUtils_SOURCES
   SMESH_File.cxx
   SMESH_MeshAlgos.cxx
   SMESH_MAT2d.cxx
-)
+  SMESH_FreeBorders.cxx
+  SMESH_ControlPnt.cxx
+  SMESH_DeMerge.cxx
+  SMESH_Delaunay.cxx
+  SMESH_FillHole.cxx
+  SMESH_Triangulate.cxx
+  SMESH_Offset.cxx
+  SMESH_Slot.cxx
+  SMESH_PolyLine.cxx
+  )
 
 # --- rules ---