Salome HOME
Zcracks plugin adaptation to new Zcracks tool
[modules/smesh.git] / src / SMESHUtils / CMakeLists.txt
index eb68432294e94546fd6cc6d8ee34c7a45496752c..c21a8a6d5c4d8e8493a50531b66bb1eff76f0e87 100644 (file)
@@ -44,6 +44,7 @@ SET(_link_LIBRARIES
   ${CAS_TKGeomBase}
   ${CAS_TKGeomAlgo}
   ${CAS_TKTopAlgo}
+  ${CAS_TKMesh}
   ${Boost_LIBRARIES}
   SMDS
 )
@@ -65,6 +66,7 @@ SET(SMESHUtils_HEADERS
   SMESH_TryCatch.hxx
   SMESH_MeshAlgos.hxx
   SMESH_MAT2d.hxx
+  SMESH_ControlPnt.hxx
 )
 
 # --- sources ---
@@ -80,6 +82,7 @@ SET(SMESHUtils_SOURCES
   SMESH_MeshAlgos.cxx
   SMESH_MAT2d.cxx
   SMESH_FreeBorders.cxx
+  SMESH_ControlPnt.cxx
 )
 
 # --- rules ---