Salome HOME
Windows compatibility
[modules/smesh.git] / src / SMESHUtils / CMakeLists.txt
index 561dba7cfa9d67989505b5930a446ae9d8e7bccd..8bafe47f4e7ec1808a0ab9bf40b510faf15e0a52 100644 (file)
@@ -25,7 +25,6 @@ INCLUDE_DIRECTORIES(
   ${VTK_INCLUDE_DIRS}
   ${Boost_INCLUDE_DIRS}
   ${PROJECT_SOURCE_DIR}/src/SMDS
-  ${PROJECT_SOURCE_DIR}/src/SMESHDS
 )
 
 # additional preprocessor / compiler flags
@@ -38,12 +37,15 @@ ADD_DEFINITIONS(
 SET(_link_LIBRARIES
   ${CAS_TKShHealing}
   ${CAS_TKPrim}
+  ${CAS_TKernel}
+  ${CAS_TKBRep}
   ${CAS_TKG2d}
   ${CAS_TKG3d}
   ${CAS_TKGeomBase}
   ${CAS_TKGeomAlgo}
+  ${CAS_TKTopAlgo}
   ${Boost_LIBRARIES}
-  SMESHDS
+  SMDS
 )
 
 # --- headers ---
@@ -62,6 +64,7 @@ SET(SMESHUtils_HEADERS
   SMESH_Utils.hxx
   SMESH_TryCatch.hxx
   SMESH_MeshAlgos.hxx
+  SMESH_MAT2d.hxx
 )
 
 # --- sources ---
@@ -75,6 +78,7 @@ SET(SMESHUtils_SOURCES
   SMESH_TryCatch.cxx
   SMESH_File.cxx
   SMESH_MeshAlgos.cxx
+  SMESH_MAT2d.cxx
 )
 
 # --- rules ---