Salome HOME
GPUSPHGUI: add FillHole() operation
[modules/smesh.git] / src / SMESHUtils / CMakeLists.txt
index 8bafe47f4e7ec1808a0ab9bf40b510faf15e0a52..6750f063c00709a06de560f81766339d186074fd 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2015  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -44,9 +44,10 @@ SET(_link_LIBRARIES
   ${CAS_TKGeomBase}
   ${CAS_TKGeomAlgo}
   ${CAS_TKTopAlgo}
+  ${CAS_TKMesh}
   ${Boost_LIBRARIES}
   SMDS
-)
+  )
 
 # --- headers ---
 
@@ -65,7 +66,9 @@ SET(SMESHUtils_HEADERS
   SMESH_TryCatch.hxx
   SMESH_MeshAlgos.hxx
   SMESH_MAT2d.hxx
-)
+  SMESH_ControlPnt.hxx
+  SMESH_Delaunay.hxx
+  )
 
 # --- sources ---
 
@@ -79,7 +82,12 @@ SET(SMESHUtils_SOURCES
   SMESH_File.cxx
   SMESH_MeshAlgos.cxx
   SMESH_MAT2d.cxx
-)
+  SMESH_FreeBorders.cxx
+  SMESH_ControlPnt.cxx
+  SMESH_DeMerge.cxx
+  SMESH_Delaunay.cxx
+  SMESH_FillHole.cxx
+  )
 
 # --- rules ---