Salome HOME
Copyright update 2021
[modules/smesh.git] / src / SMESHUtils / CMakeLists.txt
index 6750f063c00709a06de560f81766339d186074fd..652f469debac76bf2ec900f42214bf34ca9ef0b3 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2021  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # additional include directories
 INCLUDE_DIRECTORIES(
   ${KERNEL_INCLUDE_DIRS}
-  ${CAS_INCLUDE_DIRS}
-  ${VTK_INCLUDE_DIRS}
+  ${OpenCASCADE_INCLUDE_DIR}
   ${Boost_INCLUDE_DIRS}
   ${PROJECT_SOURCE_DIR}/src/SMDS
 )
 
 # additional preprocessor / compiler flags
 ADD_DEFINITIONS(
-  ${CAS_DEFINITIONS}
+  ${OpenCASCADE_DEFINITIONS}
   ${BOOST_DEFINITIONS}
 )
 
 # libraries to link to
 SET(_link_LIBRARIES
-  ${CAS_TKShHealing}
-  ${CAS_TKPrim}
-  ${CAS_TKernel}
-  ${CAS_TKBRep}
-  ${CAS_TKG2d}
-  ${CAS_TKG3d}
-  ${CAS_TKGeomBase}
-  ${CAS_TKGeomAlgo}
-  ${CAS_TKTopAlgo}
-  ${CAS_TKMesh}
-  ${Boost_LIBRARIES}
-  SMDS
-  )
+   ${OpenCASCADE_ModelingAlgorithms_LIBRARIES}
+   ${OpenCASCADE_FoundationClasses_LIBRARIES}
+   ${OpenCASCADE_ModelingData_LIBRARIES}
+   ${Boost_LIBRARIES}
+   SMDS
+)
 
 # --- headers ---
 
@@ -68,6 +60,7 @@ SET(SMESHUtils_HEADERS
   SMESH_MAT2d.hxx
   SMESH_ControlPnt.hxx
   SMESH_Delaunay.hxx
+  SMESH_Indexer.hxx
   )
 
 # --- sources ---
@@ -87,6 +80,10 @@ SET(SMESHUtils_SOURCES
   SMESH_DeMerge.cxx
   SMESH_Delaunay.cxx
   SMESH_FillHole.cxx
+  SMESH_Triangulate.cxx
+  SMESH_Offset.cxx
+  SMESH_Slot.cxx
+  SMESH_PolyLine.cxx
   )
 
 # --- rules ---