Salome HOME
-#if OCC_VERSION_LARGE > 0x06010000
[modules/smesh.git] / src / SMESHGUI / Makefile.am
index 15925385f603cb7ab08057838533111ce11b600e..f756e23507543bbaabf968bb1bd1344e30041b3f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2013  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -49,7 +49,6 @@ salomeinclude_HEADERS = \
        SMESHGUI_RemoveElementsDlg.h \
        SMESHGUI_MeshInfo.h \
        SMESHGUI_Measurements.h \
-       SMESHGUI_Preferences_ColorDlg.h \
        SMESHGUI_Preferences_ScalarBarDlg.h \
        SMESHGUI_AddMeshElementDlg.h \
        SMESHGUI_XmlHandler.h \
@@ -97,6 +96,8 @@ salomeinclude_HEADERS = \
        SMESHGUI_CopyMeshDlg.h \
        SMESHGUI_PreviewDlg.h  \
        SMESHGUI_ReorientFacesDlg.h \
+       SMESHGUI_PropertiesDlg.h \
+       SMESHGUI_Add0DElemsOnAllNodesDlg.h \
        SMESH_SMESHGUI.hxx
 
 # Libraries targets
@@ -115,7 +116,6 @@ dist_libSMESH_la_SOURCES = \
        SMESHGUI_RemoveElementsDlg.cxx \
        SMESHGUI_MeshInfo.cxx \
        SMESHGUI_Measurements.cxx \
-       SMESHGUI_Preferences_ColorDlg.cxx \
        SMESHGUI_Preferences_ScalarBarDlg.cxx \
        SMESHGUI_AddMeshElementDlg.cxx \
        SMESHGUI_XmlHandler.cxx \
@@ -173,7 +173,9 @@ dist_libSMESH_la_SOURCES = \
        SMESHGUI_CopyMeshDlg.cxx \
        SMESHGUI_FileValidator.cxx \
        SMESHGUI_PreviewDlg.cxx  \
-       SMESHGUI_ReorientFacesDlg.cxx
+       SMESHGUI_ReorientFacesDlg.cxx \
+       SMESHGUI_PropertiesDlg.cxx \
+       SMESHGUI_Add0DElemsOnAllNodesDlg.cxx
 
 MOC_FILES = \
        SMESHGUI_moc.cxx \
@@ -189,7 +191,6 @@ MOC_FILES = \
        SMESHGUI_RemoveElementsDlg_moc.cxx \
        SMESHGUI_MeshInfo_moc.cxx \
        SMESHGUI_Measurements_moc.cxx \
-       SMESHGUI_Preferences_ColorDlg_moc.cxx \
        SMESHGUI_Preferences_ScalarBarDlg_moc.cxx \
        SMESHGUI_AddMeshElementDlg_moc.cxx \
        SMESHGUI_FilterDlg_moc.cxx \
@@ -233,7 +234,9 @@ MOC_FILES = \
        SMESHGUI_CopyMeshDlg_moc.cxx \
        SMESHGUI_MeshOrderOp_moc.cxx \
        SMESHGUI_PreviewDlg_moc.cxx \
-       SMESHGUI_ReorientFacesDlg_moc.cxx
+       SMESHGUI_ReorientFacesDlg_moc.cxx \
+       SMESHGUI_PropertiesDlg_moc.cxx \
+       SMESHGUI_Add0DElemsOnAllNodesDlg_moc.cxx
 
 nodist_libSMESH_la_SOURCES= \
        $(MOC_FILES)
@@ -264,6 +267,7 @@ libSMESH_la_CPPFLAGS = \
        -I$(srcdir)/../SMESH_I \
        -I$(srcdir)/../Controls \
        -I$(srcdir)/../SMESHClient \
+       -I$(srcdir)/../MEDWrapper/Base \
        -I$(top_builddir) \
        -I$(top_builddir)/idl
 
@@ -281,4 +285,5 @@ libSMESH_la_LDFLAGS  = \
 nodist_salomeres_DATA= \
        SMESH_images.qm \
        SMESH_msg_en.qm \
-       SMESH_msg_fr.qm
+       SMESH_msg_fr.qm \
+       SMESH_msg_ja.qm