Salome HOME
Fix for the bug IPAL22854: preview is wrong for Create a new mesh
[modules/smesh.git] / src / SMESHGUI / Makefile.am
index e56d1e567fdb0126767f2eaa25f128bc480d276e..83c8ceda18181329e6ac37e99cd7fd0888383a24 100644 (file)
@@ -1,38 +1,30 @@
-#  SMESH SMESHGUI : GUI for SMESH component
+# Copyright (C) 2007-2011  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS 
-# 
-#  This library is free software; you can redistribute it and/or 
-#  modify it under the terms of the GNU Lesser General Public 
-#  License as published by the Free Software Foundation; either 
-#  version 2.1 of the License. 
-# 
-#  This library is distributed in the hope that it will be useful, 
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
-#  Lesser General Public License for more details. 
-# 
-#  You should have received a copy of the GNU Lesser General Public 
-#  License along with this library; if not, write to the Free Software 
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
-# 
-# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
-#  File   : Makefile.in
-#  Author : Nicolas REJNERI
-#  Modified by : Alexander BORODIN (OCN) - autotools usage
-#  Module : SMESH
-#  $Header$
 
+# SMESH SMESHGUI : GUI for SMESH component
+# File   : Makefile.am
+# Author : Alexander BORODIN, Open CASCADE S.A.S.
+#
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
 salomeinclude_HEADERS = \
-       SMESHGUI_Swig.hxx \
-       SMESHGUI_Swig.i \
        SMESHGUI.h \
        SMESHGUI_Utils.h \
        SMESHGUI_Hypotheses.h \
@@ -40,6 +32,70 @@ salomeinclude_HEADERS = \
        SMESHGUI_SpinBox.h \
        SMESHGUI_Selection.h \
        SMESHGUI_VTKUtils.h \
+       SMESHGUI_Displayer.h \
+       SMESHGUI_GEOMGenUtils.h \
+       SMESHGUI_MeshUtils.h \
+       SMESHGUI_FilterUtils.h \
+       SMESHGUI_PatternUtils.h \
+       SMESHGUI_GroupUtils.h \
+       SMESHGUI_PatternWidget.h \
+       SMESHGUI_CreatePatternDlg.h \
+       SMESHGUI_MeshPatternDlg.h \
+       SMESHGUI_NodesDlg.h \
+       SMESHGUI_TransparencyDlg.h \
+       SMESHGUI_ClippingDlg.h \
+       SMESHGUI_GroupDlg.h \
+       SMESHGUI_RemoveNodesDlg.h \
+       SMESHGUI_RemoveElementsDlg.h \
+       SMESHGUI_MeshInfo.h \
+       SMESHGUI_Measurements.h \
+       SMESHGUI_Preferences_ColorDlg.h \
+       SMESHGUI_Preferences_ScalarBarDlg.h \
+       SMESHGUI_AddMeshElementDlg.h \
+       SMESHGUI_XmlHandler.h \
+       SMESHGUI_Filter.h \
+       SMESHGUI_FilterDlg.h \
+       SMESHGUI_FilterLibraryDlg.h \
+       SMESHGUI_SingleEditDlg.h \
+       SMESHGUI_MultiEditDlg.h \
+       SMESHGUI_DeleteGroupDlg.h \
+       SMESHGUI_GroupOpDlg.h \
+       SMESHGUI_SmoothingDlg.h \
+       SMESHGUI_RenumberingDlg.h \
+       SMESHGUI_ExtrusionDlg.h \
+       SMESHGUI_ExtrusionAlongPathDlg.h \
+       SMESHGUI_RevolutionDlg.h \
+       SMESHGUI_RotationDlg.h \
+       SMESHGUI_TranslationDlg.h \
+       SMESHGUI_ScaleDlg.h \
+       SMESHGUI_SymmetryDlg.h \
+       SMESHGUI_SewingDlg.h \
+       SMESHGUI_DuplicateNodesDlg.h \
+       SMESHGUI_MergeDlg.h \
+       SMESHGUI_MeshUtils.h \
+       SMESHGUI_CreatePolyhedralVolumeDlg.h \
+       SMESHGUI_Operation.h \
+       SMESHGUI_SelectionOp.h \
+       SMESHGUI_Dialog.h \
+       SMESHGUI_MeshDlg.h \
+       SMESHGUI_MeshOp.h \
+       SMESHGUI_ShapeByMeshDlg.h \
+       SMESHGUI_AddQuadraticElementDlg.h \
+       SMESHGUI_ConvToQuadDlg.h \
+       SMESHGUI_ConvToQuadOp.h \
+       SMESHGUI_BuildCompoundDlg.h \
+       SMESHGUI_ComputeDlg.h \
+       SMESHGUI_MakeNodeAtPointDlg.h \
+       SMESHGUI_MeshEditPreview.h \
+       SMESHGUI_IdValidator.h \
+       SMESHGUI_MeshInfosBox.h \
+       SMESHGUI_Make2DFrom3DOp.h \
+       SMESHGUI_FindElemByPointDlg.h \
+       SMESHGUI_MeshOrderDlg.h \
+       SMESHGUI_MeshOrderOp.h \
+       SMESHGUI_FileValidator.h \
+       SMESHGUI_CopyMeshDlg.h \
+       SMESHGUI_PreviewDlg.h \
        SMESH_SMESHGUI.hxx
 
 # Libraries targets
@@ -56,14 +112,10 @@ dist_libSMESH_la_SOURCES = \
        SMESHGUI_GroupDlg.cxx \
        SMESHGUI_RemoveNodesDlg.cxx \
        SMESHGUI_RemoveElementsDlg.cxx \
-       SMESHGUI_MeshInfosDlg.cxx \
-       SMESHGUI_StandardMeshInfosDlg.cxx \
-       SMESHGUI_WhatIsDlg.cxx \
+       SMESHGUI_MeshInfo.cxx \
+       SMESHGUI_Measurements.cxx \
        SMESHGUI_Preferences_ColorDlg.cxx \
        SMESHGUI_Preferences_ScalarBarDlg.cxx \
-       SMESHGUI_Preferences_SelectionDlg.cxx \
-       SMESHGUI_Swig.cxx \
-       SMESHGUI_MoveNodesDlg.cxx \
        SMESHGUI_AddMeshElementDlg.cxx \
        SMESHGUI_XmlHandler.cxx \
        SMESHGUI_Filter.cxx \
@@ -80,10 +132,11 @@ dist_libSMESH_la_SOURCES = \
        SMESHGUI_RevolutionDlg.cxx \
        SMESHGUI_RotationDlg.cxx \
        SMESHGUI_TranslationDlg.cxx \
+       SMESHGUI_ScaleDlg.cxx \
        SMESHGUI_SymmetryDlg.cxx \
        SMESHGUI_SewingDlg.cxx \
-       SMESHGUI_MergeNodesDlg.cxx \
-       SMESHGUI_EditMeshDlg.cxx \
+       SMESHGUI_DuplicateNodesDlg.cxx \
+       SMESHGUI_MergeDlg.cxx \
        SMESHGUI_Utils.cxx \
        SMESHGUI_GEOMGenUtils.cxx \
        SMESHGUI_MeshUtils.cxx \
@@ -108,7 +161,17 @@ dist_libSMESH_la_SOURCES = \
        SMESHGUI_BuildCompoundDlg.cxx \
        SMESHGUI_ComputeDlg.cxx \
        SMESHGUI_MakeNodeAtPointDlg.cxx \
-       SMESHGUI_MeshEditPreview.cxx
+       SMESHGUI_MeshEditPreview.cxx \
+       SMESHGUI_GroupOnShapeDlg.cxx \
+       SMESHGUI_FileInfoDlg.cxx \
+       SMESHGUI_MeshInfosBox.cxx \
+       SMESHGUI_Make2DFrom3DOp.cxx \
+       SMESHGUI_FindElemByPointDlg.cxx \
+       SMESHGUI_MeshOrderDlg.cxx \
+       SMESHGUI_MeshOrderOp.cxx \
+       SMESHGUI_CopyMeshDlg.cxx \
+       SMESHGUI_FileValidator.cxx \
+       SMESHGUI_PreviewDlg.cxx
 
 MOC_FILES = \
        SMESHGUI_moc.cxx \
@@ -122,13 +185,10 @@ MOC_FILES = \
        SMESHGUI_GroupDlg_moc.cxx \
        SMESHGUI_RemoveNodesDlg_moc.cxx \
        SMESHGUI_RemoveElementsDlg_moc.cxx \
-       SMESHGUI_MeshInfosDlg_moc.cxx \
-       SMESHGUI_StandardMeshInfosDlg_moc.cxx \
-       SMESHGUI_WhatIsDlg_moc.cxx \
+       SMESHGUI_MeshInfo_moc.cxx \
+       SMESHGUI_Measurements_moc.cxx \
        SMESHGUI_Preferences_ColorDlg_moc.cxx \
        SMESHGUI_Preferences_ScalarBarDlg_moc.cxx \
-       SMESHGUI_Preferences_SelectionDlg_moc.cxx \
-       SMESHGUI_MoveNodesDlg_moc.cxx \
        SMESHGUI_AddMeshElementDlg_moc.cxx \
        SMESHGUI_FilterDlg_moc.cxx \
        SMESHGUI_FilterLibraryDlg_moc.cxx \
@@ -143,10 +203,11 @@ MOC_FILES = \
        SMESHGUI_RevolutionDlg_moc.cxx \
        SMESHGUI_RotationDlg_moc.cxx \
        SMESHGUI_TranslationDlg_moc.cxx \
+       SMESHGUI_ScaleDlg_moc.cxx \
        SMESHGUI_SymmetryDlg_moc.cxx \
        SMESHGUI_SewingDlg_moc.cxx \
-       SMESHGUI_MergeNodesDlg_moc.cxx \
-       SMESHGUI_EditMeshDlg_moc.cxx \
+       SMESHGUI_DuplicateNodesDlg_moc.cxx \
+       SMESHGUI_MergeDlg_moc.cxx \
        SMESHGUI_CreatePolyhedralVolumeDlg_moc.cxx \
        SMESHGUI_Operation_moc.cxx \
        SMESHGUI_SelectionOp_moc.cxx \
@@ -160,7 +221,16 @@ MOC_FILES = \
        SMESHGUI_ConvToQuadOp_moc.cxx \
        SMESHGUI_BuildCompoundDlg_moc.cxx \
        SMESHGUI_ComputeDlg_moc.cxx \
-       SMESHGUI_MakeNodeAtPointDlg_moc.cxx
+       SMESHGUI_MakeNodeAtPointDlg_moc.cxx \
+       SMESHGUI_GroupOnShapeDlg_moc.cxx \
+       SMESHGUI_FileInfoDlg_moc.cxx \
+       SMESHGUI_MeshInfosBox_moc.cxx \
+       SMESHGUI_Make2DFrom3DOp_moc.cxx \
+       SMESHGUI_FindElemByPointDlg_moc.cxx \
+       SMESHGUI_MeshOrderDlg_moc.cxx \
+       SMESHGUI_CopyMeshDlg_moc.cxx \
+       SMESHGUI_MeshOrderOp_moc.cxx \
+       SMESHGUI_PreviewDlg_moc.cxx
 
 nodist_libSMESH_la_SOURCES= \
        $(MOC_FILES)
@@ -174,31 +244,37 @@ libSMESH_la_CPPFLAGS = \
        $(PYTHON_INCLUDES) \
        $(KERNEL_CXXFLAGS)  \
        $(GUI_CXXFLAGS) \
+       $(QWT_INCLUDES) \
        $(GEOM_CXXFLAGS) \
        $(MED_CXXFLAGS) \
        $(BOOST_CPPFLAGS) \
        $(CORBA_CXXFLAGS) \
        $(CORBA_INCLUDES) \
+       $(MED2_INCLUDES) \
+       $(HDF5_INCLUDES) \
        -I$(srcdir)/../OBJECT \
        -I$(srcdir)/../SMESHFiltersSelection \
        -I$(srcdir)/../SMDS \
+       -I$(srcdir)/../SMESHDS \
        -I$(srcdir)/../SMESH \
        -I$(srcdir)/../SMESH_I \
        -I$(srcdir)/../Controls \
        -I$(srcdir)/../SMESHClient \
-       -I$(top_builddir)/idl \
-       -I$(top_builddir)/salome_adm/unix
-
+       -I$(top_builddir) \
+       -I$(top_builddir)/idl
 
 libSMESH_la_LDFLAGS  = \
        ../SMESHFiltersSelection/libSMESHFiltersSelection.la \
        ../SMDS/libSMDS.la \
        ../Controls/libSMESHControls.la \
        ../OBJECT/libSMESHObject.la \
-       $(GEOM_LDFLAGS) \
-       -lGEOMBase
+       $(CAS_LDFLAGS) -lTKV3d \
+       $(GUI_LDFLAGS) -lSalomePrs -lsuit -lSUITApp -lCAM -lstd \
+       $(GEOM_LDFLAGS) -lGEOMBase -lGEOMFiltersSelection -lGEOMObject \
+       $(PYTHON_LIBS)
 
 # resources files
 nodist_salomeres_DATA= \
        SMESH_images.qm \
-       SMESH_msg_en.qm
+       SMESH_msg_en.qm \
+       SMESH_msg_fr.qm