Salome HOME
0021347: [CEA 497] Visualisation into SMESH and VISU of hexagonal prism cells (MED_OC...
[modules/smesh.git] / src / SMESHGUI / Makefile.am
index 6da5d4076cf01594987c4cd99be7576a2cad4112..83c8ceda18181329e6ac37e99cd7fd0888383a24 100644 (file)
@@ -1,20 +1,20 @@
-#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2011  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
 # SMESH SMESHGUI : GUI for SMESH component
@@ -95,6 +95,7 @@ salomeinclude_HEADERS = \
        SMESHGUI_MeshOrderOp.h \
        SMESHGUI_FileValidator.h \
        SMESHGUI_CopyMeshDlg.h \
+       SMESHGUI_PreviewDlg.h \
        SMESH_SMESHGUI.hxx
 
 # Libraries targets
@@ -169,7 +170,8 @@ dist_libSMESH_la_SOURCES = \
        SMESHGUI_MeshOrderDlg.cxx \
        SMESHGUI_MeshOrderOp.cxx \
        SMESHGUI_CopyMeshDlg.cxx \
-       SMESHGUI_FileValidator.cxx
+       SMESHGUI_FileValidator.cxx \
+       SMESHGUI_PreviewDlg.cxx
 
 MOC_FILES = \
        SMESHGUI_moc.cxx \
@@ -227,7 +229,8 @@ MOC_FILES = \
        SMESHGUI_FindElemByPointDlg_moc.cxx \
        SMESHGUI_MeshOrderDlg_moc.cxx \
        SMESHGUI_CopyMeshDlg_moc.cxx \
-       SMESHGUI_MeshOrderOp_moc.cxx
+       SMESHGUI_MeshOrderOp_moc.cxx \
+       SMESHGUI_PreviewDlg_moc.cxx
 
 nodist_libSMESH_la_SOURCES= \
        $(MOC_FILES)
@@ -241,6 +244,7 @@ libSMESH_la_CPPFLAGS = \
        $(PYTHON_INCLUDES) \
        $(KERNEL_CXXFLAGS)  \
        $(GUI_CXXFLAGS) \
+       $(QWT_INCLUDES) \
        $(GEOM_CXXFLAGS) \
        $(MED_CXXFLAGS) \
        $(BOOST_CPPFLAGS) \
@@ -251,10 +255,12 @@ libSMESH_la_CPPFLAGS = \
        -I$(srcdir)/../OBJECT \
        -I$(srcdir)/../SMESHFiltersSelection \
        -I$(srcdir)/../SMDS \
+       -I$(srcdir)/../SMESHDS \
        -I$(srcdir)/../SMESH \
        -I$(srcdir)/../SMESH_I \
        -I$(srcdir)/../Controls \
        -I$(srcdir)/../SMESHClient \
+       -I$(top_builddir) \
        -I$(top_builddir)/idl
 
 libSMESH_la_LDFLAGS  = \
@@ -264,7 +270,8 @@ libSMESH_la_LDFLAGS  = \
        ../OBJECT/libSMESHObject.la \
        $(CAS_LDFLAGS) -lTKV3d \
        $(GUI_LDFLAGS) -lSalomePrs -lsuit -lSUITApp -lCAM -lstd \
-       $(GEOM_LDFLAGS) -lGEOMBase -lGEOMFiltersSelection -lGEOMObject
+       $(GEOM_LDFLAGS) -lGEOMBase -lGEOMFiltersSelection -lGEOMObject \
+       $(PYTHON_LIBS)
 
 # resources files
 nodist_salomeres_DATA= \