Salome HOME
Merge from V6_5_BR 05/06/2012
[modules/smesh.git] / src / SMESHGUI / Makefile.am
index 7e7448f59556982a622799adcf6fcd36c6458315..28537546a779ed23a03ad36a6eeb35ce1b0e1a65 100644 (file)
@@ -1,20 +1,20 @@
-#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
 # SMESH SMESHGUI : GUI for SMESH component
@@ -94,6 +94,8 @@ salomeinclude_HEADERS = \
        SMESHGUI_MeshOrderDlg.h \
        SMESHGUI_MeshOrderOp.h \
        SMESHGUI_FileValidator.h \
+       SMESHGUI_CopyMeshDlg.h \
+       SMESHGUI_PreviewDlg.h \
        SMESH_SMESHGUI.hxx
 
 # Libraries targets
@@ -167,7 +169,9 @@ dist_libSMESH_la_SOURCES = \
        SMESHGUI_FindElemByPointDlg.cxx \
        SMESHGUI_MeshOrderDlg.cxx \
        SMESHGUI_MeshOrderOp.cxx \
-       SMESHGUI_FileValidator.cxx
+       SMESHGUI_CopyMeshDlg.cxx \
+       SMESHGUI_FileValidator.cxx \
+       SMESHGUI_PreviewDlg.cxx
 
 MOC_FILES = \
        SMESHGUI_moc.cxx \
@@ -224,7 +228,9 @@ MOC_FILES = \
        SMESHGUI_Make2DFrom3DOp_moc.cxx \
        SMESHGUI_FindElemByPointDlg_moc.cxx \
        SMESHGUI_MeshOrderDlg_moc.cxx \
-       SMESHGUI_MeshOrderOp_moc.cxx
+       SMESHGUI_CopyMeshDlg_moc.cxx \
+       SMESHGUI_MeshOrderOp_moc.cxx \
+       SMESHGUI_PreviewDlg_moc.cxx
 
 nodist_libSMESH_la_SOURCES= \
        $(MOC_FILES)
@@ -238,20 +244,24 @@ libSMESH_la_CPPFLAGS = \
        $(PYTHON_INCLUDES) \
        $(KERNEL_CXXFLAGS)  \
        $(GUI_CXXFLAGS) \
+       $(QWT_INCLUDES) \
        $(GEOM_CXXFLAGS) \
        $(MED_CXXFLAGS) \
        $(BOOST_CPPFLAGS) \
        $(CORBA_CXXFLAGS) \
        $(CORBA_INCLUDES) \
-       $(MED2_INCLUDES) \
+       $(MED3_INCLUDES) \
        $(HDF5_INCLUDES) \
        -I$(srcdir)/../OBJECT \
        -I$(srcdir)/../SMESHFiltersSelection \
        -I$(srcdir)/../SMDS \
+       -I$(srcdir)/../SMESHDS \
        -I$(srcdir)/../SMESH \
+       -I$(srcdir)/../SMESHUtils \
        -I$(srcdir)/../SMESH_I \
        -I$(srcdir)/../Controls \
        -I$(srcdir)/../SMESHClient \
+       -I$(top_builddir) \
        -I$(top_builddir)/idl
 
 libSMESH_la_LDFLAGS  = \
@@ -261,7 +271,8 @@ libSMESH_la_LDFLAGS  = \
        ../OBJECT/libSMESHObject.la \
        $(CAS_LDFLAGS) -lTKV3d \
        $(GUI_LDFLAGS) -lSalomePrs -lsuit -lSUITApp -lCAM -lstd \
-       $(GEOM_LDFLAGS) -lGEOMBase -lGEOMFiltersSelection -lGEOMObject
+       $(GEOM_LDFLAGS) -lGEOMBase -lGEOMFiltersSelection -lGEOMObject \
+       $(PYTHON_LIBS)
 
 # resources files
 nodist_salomeres_DATA= \