Salome HOME
0019970: create groups automatically
[modules/smesh.git] / src / SMESHGUI / Makefile.am
index 6e451fb7d03a810d4731f6d5db853cd25fce435e..1fc4b43b3592df02a0a473443551f58a6124ca5a 100644 (file)
@@ -34,6 +34,62 @@ salomeinclude_HEADERS = \
        SMESHGUI_SpinBox.h \
        SMESHGUI_Selection.h \
        SMESHGUI_VTKUtils.h \
+       SMESHGUI_Displayer.h \
+       SMESHGUI_GEOMGenUtils.h \
+       SMESHGUI_MeshUtils.h \
+       SMESHGUI_FilterUtils.h \
+       SMESHGUI_PatternUtils.h \
+       SMESHGUI_GroupUtils.h \
+       SMESHGUI_PatternWidget.h \
+       SMESHGUI_CreatePatternDlg.h \
+       SMESHGUI_MeshPatternDlg.h \
+       SMESHGUI_NodesDlg.h \
+       SMESHGUI_TransparencyDlg.h \
+       SMESHGUI_ClippingDlg.h \
+       SMESHGUI_GroupDlg.h \
+       SMESHGUI_RemoveNodesDlg.h \
+       SMESHGUI_RemoveElementsDlg.h \
+       SMESHGUI_MeshInfosDlg.h \
+       SMESHGUI_StandardMeshInfosDlg.h \
+       SMESHGUI_WhatIsDlg.h \
+       SMESHGUI_Preferences_ColorDlg.h \
+       SMESHGUI_Preferences_ScalarBarDlg.h \
+       SMESHGUI_MoveNodesDlg.h \
+       SMESHGUI_AddMeshElementDlg.h \
+       SMESHGUI_XmlHandler.h \
+       SMESHGUI_Filter.h \
+       SMESHGUI_FilterDlg.h \
+       SMESHGUI_FilterLibraryDlg.h \
+       SMESHGUI_SingleEditDlg.h \
+       SMESHGUI_MultiEditDlg.h \
+       SMESHGUI_DeleteGroupDlg.h \
+       SMESHGUI_GroupOpDlg.h \
+       SMESHGUI_SmoothingDlg.h \
+       SMESHGUI_RenumberingDlg.h \
+       SMESHGUI_ExtrusionDlg.h \
+       SMESHGUI_ExtrusionAlongPathDlg.h \
+       SMESHGUI_RevolutionDlg.h \
+       SMESHGUI_RotationDlg.h \
+       SMESHGUI_TranslationDlg.h \
+       SMESHGUI_SymmetryDlg.h \
+       SMESHGUI_SewingDlg.h \
+       SMESHGUI_EditMeshDlg.h \
+       SMESHGUI_MeshUtils.h \
+       SMESHGUI_CreatePolyhedralVolumeDlg.h \
+       SMESHGUI_Operation.h \
+       SMESHGUI_SelectionOp.h \
+       SMESHGUI_Dialog.h \
+       SMESHGUI_MeshDlg.h \
+       SMESHGUI_MeshOp.h \
+       SMESHGUI_ShapeByMeshDlg.h \
+       SMESHGUI_AddQuadraticElementDlg.h \
+       SMESHGUI_ConvToQuadDlg.h \
+       SMESHGUI_ConvToQuadOp.h \
+       SMESHGUI_BuildCompoundDlg.h \
+       SMESHGUI_ComputeDlg.h \
+       SMESHGUI_MakeNodeAtPointDlg.h \
+       SMESHGUI_MeshEditPreview.h \
+       SMESHGUI_IdValidator.h \
        SMESH_SMESHGUI.hxx
 
 # Libraries targets
@@ -100,6 +156,7 @@ dist_libSMESH_la_SOURCES = \
        SMESHGUI_ComputeDlg.cxx \
        SMESHGUI_MakeNodeAtPointDlg.cxx \
        SMESHGUI_MeshEditPreview.cxx \
+       SMESHGUI_GroupOnShapeDlg.cxx \
        SMESHGUI_FileInfoDlg.cxx
 
 MOC_FILES = \
@@ -151,6 +208,7 @@ MOC_FILES = \
        SMESHGUI_BuildCompoundDlg_moc.cxx \
        SMESHGUI_ComputeDlg_moc.cxx \
        SMESHGUI_MakeNodeAtPointDlg_moc.cxx \
+       SMESHGUI_GroupOnShapeDlg_moc.cxx \
        SMESHGUI_FileInfoDlg_moc.cxx
 
 nodist_libSMESH_la_SOURCES= \
@@ -170,6 +228,8 @@ libSMESH_la_CPPFLAGS = \
        $(BOOST_CPPFLAGS) \
        $(CORBA_CXXFLAGS) \
        $(CORBA_INCLUDES) \
+       $(MED2_INCLUDES) \
+       $(HDF5_INCLUDES) \
        -I$(srcdir)/../OBJECT \
        -I$(srcdir)/../SMESHFiltersSelection \
        -I$(srcdir)/../SMDS \