Salome HOME
IPAL52702: TC7.6.0: Incorrect large name of SMESH group in the Object Browser
[modules/smesh.git] / src / SMESHGUI / CMakeLists.txt
index 725c34ae2adbf4db92e55adcb86f034dedcb94ea..ed8b7836e5572cb8d5ca4769e38d341d5495e16c 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2015  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -39,9 +39,7 @@ INCLUDE_DIRECTORIES(
   ${PROJECT_SOURCE_DIR}/src/SMESHFiltersSelection
   ${PROJECT_SOURCE_DIR}/src/SMDS
   ${PROJECT_SOURCE_DIR}/src/SMESHDS
-  ${PROJECT_SOURCE_DIR}/src/SMESH
   ${PROJECT_SOURCE_DIR}/src/SMESHUtils
-  ${PROJECT_SOURCE_DIR}/src/SMESH_I
   ${PROJECT_SOURCE_DIR}/src/Controls
   ${PROJECT_SOURCE_DIR}/src/SMESHClient
   ${PROJECT_SOURCE_DIR}/src/MEDWrapper/Base
@@ -56,6 +54,11 @@ ADD_DEFINITIONS(
   ${OMNIORB_DEFINITIONS}
 )
 
+# To avoid GetObject macro definition on WIN32
+IF(WIN32)
+  ADD_DEFINITIONS(-DNOGDI)
+ENDIF(WIN32)
+
 # libraries to link to
 SET(_link_LIBRARIES
   ${CAS_TKV3d}
@@ -136,10 +139,13 @@ SET(_moc_HEADERS
   SMESHGUI_ReorientFacesDlg.h
   SMESHGUI_PropertiesDlg.h
   SMESHGUI_Add0DElemsOnAllNodesDlg.h
+  SMESHGUI_FieldSelectorWdg.h
+  SMESHGUI_DisplayEntitiesDlg.h
 )
 
 # header files / no moc processing
 SET(_other_HEADERS
+  SMESHGUI_Operations.h
   SMESHGUI_Utils.h
   SMESHGUI_HypothesesUtils.h
   SMESHGUI_Selection.h
@@ -241,6 +247,8 @@ SET(_other_SOURCES
   SMESHGUI_Filter.cxx
   SMESHGUI_MeshEditPreview.cxx
   SMESHGUI_FileValidator.cxx
+  SMESHGUI_FieldSelectorWdg.cxx
+  SMESHGUI_DisplayEntitiesDlg.cxx
 )
 
 # sources / to compile