Salome HOME
Added a new enumeration for smesh menus
[modules/smesh.git] / src / SMESHGUI / CMakeLists.txt
index 725c34ae2adbf4db92e55adcb86f034dedcb94ea..d92818942747496b2d24ef0ba22587c8458025e9 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2014  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -56,6 +56,11 @@ ADD_DEFINITIONS(
   ${OMNIORB_DEFINITIONS}
 )
 
+# To avoid GetObject macro definition on WIN32
+IF(WIN32)
+  ADD_DEFINITIONS(-DNOGDI)
+ENDIF(WIN32)
+
 # libraries to link to
 SET(_link_LIBRARIES
   ${CAS_TKV3d}
@@ -136,10 +141,12 @@ SET(_moc_HEADERS
   SMESHGUI_ReorientFacesDlg.h
   SMESHGUI_PropertiesDlg.h
   SMESHGUI_Add0DElemsOnAllNodesDlg.h
+  SMESHGUI_FieldSelectorWdg.h
 )
 
 # header files / no moc processing
 SET(_other_HEADERS
+  SMESHGUI_Operations.h
   SMESHGUI_Utils.h
   SMESHGUI_HypothesesUtils.h
   SMESHGUI_Selection.h
@@ -241,6 +248,7 @@ SET(_other_SOURCES
   SMESHGUI_Filter.cxx
   SMESHGUI_MeshEditPreview.cxx
   SMESHGUI_FileValidator.cxx
+  SMESHGUI_FieldSelectorWdg.cxx
 )
 
 # sources / to compile