Salome HOME
[bos #40653][CEA] New mesh import export formats with meshio.
[modules/smesh.git] / src / SMESHGUI / CMakeLists.txt
index 258033585a049cc6c69990c3755613dd0da04486..6d83cf9543f804ef86e453570d3663328b9c1fea 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2024  CEA, EDF, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -23,7 +23,6 @@ INCLUDE(UseQtExt)
 # additional include directories
 INCLUDE_DIRECTORIES(
   ${QT_INCLUDES}
-  ${VTK_INCLUDE_DIRS}
   ${OGL_INCLUDE_DIRS}
   ${OpenCASCADE_INCLUDE_DIR}
   ${PYTHON_INCLUDE_DIRS}
@@ -35,6 +34,7 @@ INCLUDE_DIRECTORIES(
   ${Boost_INCLUDE_DIRS}
   ${OMNIORB_INCLUDE_DIR}
   ${HDF5_INCLUDE_DIRS}
+  ${MEDCOUPLING_INCLUDE_DIRS}
   ${PROJECT_SOURCE_DIR}/src/OBJECT
   ${PROJECT_SOURCE_DIR}/src/SMESHFiltersSelection
   ${PROJECT_SOURCE_DIR}/src/SMDS
@@ -43,6 +43,8 @@ INCLUDE_DIRECTORIES(
   ${PROJECT_SOURCE_DIR}/src/Controls
   ${PROJECT_SOURCE_DIR}/src/SMESHClient
   ${PROJECT_SOURCE_DIR}/src/MEDWrapper
+  ${PROJECT_SOURCE_DIR}/src/SMESH_I
+  ${PROJECT_SOURCE_DIR}/src/SMESH
   ${PROJECT_BINARY_DIR}
   ${PROJECT_BINARY_DIR}/idl
 )
@@ -74,6 +76,7 @@ SET(_link_LIBRARIES
   SMDS
   SMESHControls
   SMESHObject
+  SMESHEngine
 )
 
 # --- headers ---
@@ -103,6 +106,7 @@ SET(_moc_HEADERS
   SMESHGUI_MultiEditDlg.h
   SMESHGUI_DeleteGroupDlg.h
   SMESHGUI_GroupOpDlg.h
+  SMESHGUI_FaceGroupsSeparatedByEdgesDlg.h
   SMESHGUI_SmoothingDlg.h
   SMESHGUI_RenumberingDlg.h
   SMESHGUI_ExtrusionDlg.h
@@ -132,6 +136,7 @@ SET(_moc_HEADERS
   SMESHGUI_MakeNodeAtPointDlg.h
   SMESHGUI_MeshInfosBox.h
   SMESHGUI_Make2DFrom3DOp.h
+  SMESHGUI_MakeFull2DFrom3DOp.h
   SMESHGUI_FindElemByPointDlg.h
   SMESHGUI_MeshOrderDlg.h
   SMESHGUI_CopyMeshDlg.h
@@ -144,6 +149,19 @@ SET(_moc_HEADERS
   SMESHGUI_DisplayEntitiesDlg.h
   SMESHGUI_SplitBiQuad.h
   SMESHGUI_IdPreview.h
+  SMESHGUI_PreVisualObj.h
+  SMESHGUI_MG_ADAPTDRIVER.h
+  SMESHGUI_MgAdaptDlg.h
+  SMESHGUI_HomardAdaptDlg.h
+  SMESHGUI_HomardBoundaryDlg.h
+  SMESHGUI_HomardListGroup.h
+  SMESHGUI_RemoveNodeReconnectionDlg.h
+  SMESHGUI_AddNodeOnSegmentDlg.h
+  SMESHGUI_AddNodeOnFaceDlg.h
+  SMESHGUI_InteractiveOp.h
+  SMESHGUI_CreateDualMeshDlg.h
+  SMESHGUI_CreateDualMeshOp.h
+  SMESHGUI_Meshio.h
 )
 
 # header files / no moc processing
@@ -164,7 +182,9 @@ SET(_other_HEADERS
   SMESHGUI_MeshEditPreview.h
   SMESHGUI_IdValidator.h
   SMESHGUI_FileValidator.h
+  SMESHGUI_SelectionProxy.h
   SMESH_SMESHGUI.hxx
+  SMESHGUI_HomardUtils.h
 )
 
 # header files / to install
@@ -188,6 +208,7 @@ SET(_other_SOURCES
   SMESHGUI_GroupDlg.cxx
   SMESHGUI_RemoveNodesDlg.cxx
   SMESHGUI_RemoveElementsDlg.cxx
+  SMESHGUI_SelectionProxy.cxx
   SMESHGUI_MeshInfo.cxx
   SMESHGUI_Measurements.cxx
   SMESHGUI_Preferences_ScalarBarDlg.cxx
@@ -198,6 +219,7 @@ SET(_other_SOURCES
   SMESHGUI_MultiEditDlg.cxx
   SMESHGUI_DeleteGroupDlg.cxx
   SMESHGUI_GroupOpDlg.cxx
+  SMESHGUI_FaceGroupsSeparatedByEdgesDlg.cxx
   SMESHGUI_SmoothingDlg.cxx
   SMESHGUI_RenumberingDlg.cxx
   SMESHGUI_ExtrusionDlg.cxx
@@ -229,6 +251,7 @@ SET(_other_SOURCES
   SMESHGUI_FileInfoDlg.cxx
   SMESHGUI_MeshInfosBox.cxx
   SMESHGUI_Make2DFrom3DOp.cxx
+  SMESHGUI_MakeFull2DFrom3DOp.cxx
   SMESHGUI_FindElemByPointDlg.cxx
   SMESHGUI_MeshOrderDlg.cxx
   SMESHGUI_CopyMeshDlg.cxx
@@ -256,6 +279,19 @@ SET(_other_SOURCES
   SMESHGUI_SplitBiQuad.cxx
   SMESHGUI_PreVisualObj.cxx
   SMESHGUI_IdPreview.cxx
+  SMESHGUI_MG_ADAPTDRIVER.cxx
+  SMESHGUI_MgAdaptDlg.cxx
+  SMESHGUI_HomardUtils.cxx
+  SMESHGUI_HomardAdaptDlg.cxx
+  SMESHGUI_HomardBoundaryDlg.cxx
+  SMESHGUI_HomardListGroup.cxx
+  SMESHGUI_RemoveNodeReconnectionDlg.cxx
+  SMESHGUI_AddNodeOnSegmentDlg.cxx
+  SMESHGUI_AddNodeOnFaceDlg.cxx
+  SMESHGUI_InteractiveOp.cxx
+  SMESHGUI_CreateDualMeshDlg.cxx
+  SMESHGUI_CreateDualMeshOp.cxx
+  SMESHGUI_Meshio.cxx
 )
 
 # sources / to compile
@@ -269,7 +305,10 @@ SET(_ts_RESOURCES
   SMESH_msg_en.ts
   SMESH_msg_fr.ts
   SMESH_msg_ja.ts
-) 
+  SMESHGUI_Homard_msg_en.ts
+  SMESHGUI_Homard_msg_fr.ts
+  SMESHGUI_Homard_msg_ja.ts
+)
 
 # --- rules ---