Salome HOME
22784: EDF 8824 GHS3DPLUGIN: SetEnforcedVertexNamedWithGroup() does not add an extra...
[modules/smesh.git] / src / SMESHGUI / CMakeLists.txt
index 7852ef6de3e1f2bdfd388c520286924c5b1104ab..59a99865b3a2313c63910c2cacd3cc2df138d383 100644 (file)
@@ -74,7 +74,6 @@ SET(_link_LIBRARIES
   ${GEOM_GEOMObject}
   SMESHFiltersSelection
   SMDS
-  SMESHEngine
   SMESHControls
   SMESHObject
 )
@@ -143,10 +142,12 @@ SET(_moc_HEADERS
   SMESHGUI_PropertiesDlg.h
   SMESHGUI_Add0DElemsOnAllNodesDlg.h
   SMESHGUI_FieldSelectorWdg.h
+  SMESHGUI_DisplayEntitiesDlg.h
 )
 
 # header files / no moc processing
 SET(_other_HEADERS
+  SMESHGUI_Operations.h
   SMESHGUI_Utils.h
   SMESHGUI_HypothesesUtils.h
   SMESHGUI_Selection.h
@@ -249,6 +250,7 @@ SET(_other_SOURCES
   SMESHGUI_MeshEditPreview.cxx
   SMESHGUI_FileValidator.cxx
   SMESHGUI_FieldSelectorWdg.cxx
+  SMESHGUI_DisplayEntitiesDlg.cxx
 )
 
 # sources / to compile