Salome HOME
Mise à jour des références
[modules/smesh.git] / src / SMESHFiltersSelection / CMakeLists.txt
index 7a9b9566b2ca905b6cef759e1ecdd343360e6990..1863291c98f5b789d899685c146fa85cb2501820 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2020  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
 # --- options ---
 # additional include directories
 INCLUDE_DIRECTORIES(
-  ${CAS_INCLUDE_DIRS}
+  ${OpenCASCADE_INCLUDE_DIR}
   ${QT_INCLUDES}
   ${PYTHON_INCLUDE_DIRS}
-  ${VTK_INCLUDE_DIRS}
   ${KERNEL_INCLUDE_DIRS}
   ${GUI_INCLUDE_DIRS}
   ${GEOM_INCLUDE_DIRS}
@@ -37,7 +36,7 @@ INCLUDE_DIRECTORIES(
 ADD_DEFINITIONS(
   ${OMNIORB_DEFINITIONS}
   ${PYTHON_DEFINITIONS}
-  ${CAS_DEFINITIONS}
+  ${OpenCASCADE_DEFINITIONS}
 )
 
 # libraries to link to
@@ -46,12 +45,9 @@ SET(_link_LIBRARIES
   ${KERNEL_SalomeDS}
   ${GUI_SalomeApp}
   ${GUI_suit}
-  ${GUI_LightApp}
-  ${GEOM_GEOM}
   ${GEOM_GEOMClient}
-  ${CAS_TKernel}
-  ${CAS_TKMath}
-  ${CAS_TKBRep}
+  ${OpenCASCADE_FoundationClasses_LIBRARIES}
+  ${OpenCASCADE_ModelingData_LIBRARIES}
   SalomeIDLSMESH
 )