Salome HOME
Merge Python 3 porting.
[modules/smesh.git] / src / SMESHDS / CMakeLists.txt
index 4359252ffb1ea909af522e2632d837ffa538bd57..e5c153ceae634850a87c02347701cb2497501081 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
 
 # --- options ---
 # additional include directories
+
+IF(SALOME_SMESH_USE_TBB)
+  SET(TBB_INCLUDES ${TBB_INCLUDE_DIRS})
+ENDIF(SALOME_SMESH_USE_TBB)
+
 INCLUDE_DIRECTORIES(
   ${KERNEL_INCLUDE_DIRS}
   ${CAS_INCLUDE_DIRS}
   ${VTK_INCLUDE_DIRS}
   ${Boost_INCLUDE_DIRS}
   ${PROJECT_SOURCE_DIR}/src/SMDS
-
+  ${TBB_INCLUDES}
 )
 
 # additional preprocessor / compiler flags
@@ -34,12 +39,17 @@ ADD_DEFINITIONS(
   ${BOOST_DEFINITIONS}
 )
 
+IF(SALOME_SMESH_USE_TBB)
+  SET(TBB_LIBS ${TBB_LIBRARIES})
+ENDIF(SALOME_SMESH_USE_TBB)
+
 # libraries to link to
 SET(_link_LIBRARIES
   ${CAS_KERNEL}
   ${CAS_TKBRep}
   ${KERNEL_SALOMELocalTrace}
   SMDS
+  ${TBB_LIBS}
 )
 
 # --- headers ---