Salome HOME
Merge from V5_1_main 14/05/2010
[modules/smesh.git] / src / SMESHClient / Makefile.am
index ebb0d97f770ebb4bf6f5951d30382550a45388f8..fcaf9b2e6145ac72721f734037e6cbb93f8e3535 100644 (file)
@@ -1,7 +1,4 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
-#
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 #  This library is free software; you can redistribute it and/or
 #  modify it under the terms of the GNU Lesser General Public
@@ -19,6 +16,7 @@
 #
 #  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 #  GEOM GEOMClient : tool to transfer BREP files from GEOM server to GEOM client
 #  File   : Makefile.in
 #  Author : Pavel TELKOV (OCC)
@@ -59,8 +57,7 @@ libSMESHClient_la_CPPFLAGS = \
        -I$(srcdir)/../SMDS \
        -I$(srcdir)/../SMESHDS \
        -I$(srcdir)/../SMESH \
-       -I$(top_builddir)/idl \
-       -I$(top_builddir)/salome_adm/unix
+       -I$(top_builddir)/idl
 
 libSMESHClient_la_LDFLAGS  = \
        ../../idl/libSalomeIDLSMESH.la \
@@ -68,7 +65,7 @@ libSMESHClient_la_LDFLAGS  = \
        ../SMESH/libSMESHimpl.la \
        ../SMESHDS/libSMESHDS.la \
        ../Controls/libSMESHControls.la \
-       $(KERNEL_LDFLAGS) -lSalomeLifeCycleCORBA \
+       $(KERNEL_LDFLAGS) -lSalomeLifeCycleCORBA -lSalomeNS -lOpUtil -lSALOMEBasics \
        $(GEOM_LDFLAGS) -lNMTDS \
        $(MED_LDFLAGS) -lMEDWrapper_V2_2 -lMEDWrapper_V2_1 \
        $(CAS_KERNEL)