Salome HOME
Merge branch 'V8_4_BR'
[modules/smesh.git] / src / SMESHClient / CMakeLists.txt
index 7a7b4e92e5b8674c80e1683d1d3ee1ab1e6bfb57..e8c582ffe5833712cdc966ef41b580e05823ccd8 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -25,7 +25,7 @@ INCLUDE_DIRECTORIES(
   ${GEOM_INCLUDE_DIRS}
   ${Boost_INCLUDE_DIRS}
   ${VTK_INCLUDE_DIRS}
-  ${CAS_INCLUDE_DIRS}
+  ${OpenCASCADE_INCLUDE_DIR}
   ${OMNIORB_INCLUDE_DIR}
   ${PROJECT_SOURCE_DIR}/src/Controls
   ${PROJECT_SOURCE_DIR}/src/Driver
@@ -43,7 +43,7 @@ INCLUDE_DIRECTORIES(
 # additional preprocessor / compiler flags
 ADD_DEFINITIONS(
   ${OMNIORB_DEFINITIONS}
-  ${CAS_DEFINITIONS}
+  ${OpenCASCADE_DEFINITIONS}
   ${BOOST_DEFINITIONS}
 )
 
@@ -64,7 +64,7 @@ SET(_link_LIBRARIES
   ${KERNEL_SALOMELocalTrace}
   ${GEOM_NMTDS}
   ${GEOM_SalomeIDLGEOM}  
-  ${CAS_KERNEL}
+  ${OpenCASCADE_KERNEL}
   SalomeIDLSMESH
   SMDS
   SMESHimpl
@@ -89,19 +89,11 @@ SET(SMESHClient_SOURCES
   SMESH_Client.cxx
 )
 
-# bin programs
-SET(SMESHClientBin_SOURCES
-  SMESHClientBin.cxx
-)
-
 # --- rules ---
 
 ADD_LIBRARY(SMESHClient ${SMESHClient_SOURCES})
 TARGET_LINK_LIBRARIES(SMESHClient ${_link_LIBRARIES} )
 INSTALL(TARGETS SMESHClient EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 
-ADD_EXECUTABLE(SMESHClientBin ${SMESHClientBin_SOURCES})
-TARGET_LINK_LIBRARIES(SMESHClientBin ${_link_LIBRARIES})
-INSTALL(TARGETS SMESHClientBin EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_BINS})
 
 INSTALL(FILES ${SMESHClient_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})