Salome HOME
Copyright update 2022
[modules/smesh.git] / src / SMESHClient / CMakeLists.txt
index e103f174ce55f791342e7b7e90f892d78cf0de30..5511a4589e10236fd6b6b872e644b4ac87348251 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2022  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -24,9 +24,9 @@ INCLUDE_DIRECTORIES(
   ${MEDFILE_INCLUDE_DIRS}
   ${GEOM_INCLUDE_DIRS}
   ${Boost_INCLUDE_DIRS}
-  ${VTK_INCLUDE_DIRS}
-  ${CAS_INCLUDE_DIRS}
+  ${OpenCASCADE_INCLUDE_DIR}
   ${OMNIORB_INCLUDE_DIR}
+  ${MEDCOUPLING_INCLUDE_DIRS}
   ${PROJECT_SOURCE_DIR}/src/Controls
   ${PROJECT_SOURCE_DIR}/src/Driver
   ${PROJECT_SOURCE_DIR}/src/DriverDAT
@@ -37,13 +37,14 @@ INCLUDE_DIRECTORIES(
   ${PROJECT_SOURCE_DIR}/src/SMESHDS
   ${PROJECT_SOURCE_DIR}/src/SMESH
   ${PROJECT_SOURCE_DIR}/src/SMESHUtils
+  ${PROJECT_SOURCE_DIR}/src/SMESH_I
   ${PROJECT_BINARY_DIR}/idl
 )
 
 # additional preprocessor / compiler flags
 ADD_DEFINITIONS(
   ${OMNIORB_DEFINITIONS}
-  ${CAS_DEFINITIONS}
+  ${OpenCASCADE_DEFINITIONS}
   ${BOOST_DEFINITIONS}
 )
 
@@ -64,15 +65,14 @@ SET(_link_LIBRARIES
   ${KERNEL_SALOMELocalTrace}
   ${GEOM_NMTDS}
   ${GEOM_SalomeIDLGEOM}  
-  ${CAS_KERNEL}
+  ${OpenCASCADE_KERNEL}
   SalomeIDLSMESH
   SMDS
   SMESHimpl
   SMESHDS
   SMESHControls
+  SMESHEngine 
   MEDWrapper
-  MEDWrapperBase
-  MEDWrapper_V2_2
 )
 
 # --- headers ---