Salome HOME
Fix make distcheck problem
[modules/smesh.git] / src / SMESH / Makefile.am
index 8ea7e5734b8854f647ba120abbd2bac3dcd7b4d0..47543642883ce6afd8481d75c44aa445beda1390 100644 (file)
@@ -1,32 +1,29 @@
-#  SMESH SMESH : implementaion of SMESH idl descriptions
+#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+#
+#  This library is free software; you can redistribute it and/or
+#  modify it under the terms of the GNU Lesser General Public
+#  License as published by the Free Software Foundation; either
+#  version 2.1 of the License.
 #
-#  Copyright (C) 2003  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS 
-# 
-#  This library is free software; you can redistribute it and/or 
-#  modify it under the terms of the GNU Lesser General Public 
-#  License as published by the Free Software Foundation; either 
-#  version 2.1 of the License. 
-# 
-#  This library is distributed in the hope that it will be useful, 
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
-#  Lesser General Public License for more details. 
-# 
-#  You should have received a copy of the GNU Lesser General Public 
-#  License along with this library; if not, write to the Free Software 
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
-# 
-# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+#  This library is distributed in the hope that it will be useful,
+#  but WITHOUT ANY WARRANTY; without even the implied warranty of
+#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+#  Lesser General Public License for more details.
 #
+#  You should have received a copy of the GNU Lesser General Public
+#  License along with this library; if not, write to the Free Software
+#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
+#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
+#  SMESH SMESH : implementaion of SMESH idl descriptions
 #  File   : Makefile.in
 #  Author : Paul RASCLE, EDF
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : SMESH
 #  $Header$
-
+#
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
@@ -55,6 +52,7 @@ salomeinclude_HEADERS = \
        SMESH_OctreeNode.hxx \
        SMESH_Comment.hxx \
        SMESH_ComputeError.hxx \
+       SMESH_File.hxx \
        SMESH_SMESH.hxx
 
 # Libraries targets
@@ -62,6 +60,7 @@ salomeinclude_HEADERS = \
 lib_LTLIBRARIES = libSMESHimpl.la
 
 dist_libSMESHimpl_la_SOURCES = \
+       memoire.h \
        SMESH_Gen.cxx \
        SMESH_Mesh.cxx \
        SMESH_subMesh.cxx \
@@ -78,15 +77,17 @@ dist_libSMESHimpl_la_SOURCES = \
        SMESH_HypoFilter.cxx \
        SMESH_MesherHelper.cxx \
        SMESH_Octree.cxx \
-       SMESH_OctreeNode.cxx
+       SMESH_OctreeNode.cxx \
+       SMESH_File.cxx
 
 # additionnal information to compile and link file
 libSMESHimpl_la_CPPFLAGS = \
        $(KERNEL_CXXFLAGS) \
+       $(CAS_CPPFLAGS) \
        $(MED_CXXFLAGS) \
        $(GEOM_CXX_FLAGS) \
+        $(VTK_INCLUDES) \
        $(BOOST_CPPFLAGS) \
-       $(CAS_CPPFLAGS) \
        @HDF5_INCLUDES@ \
        -I$(srcdir)/../Controls \
        -I$(srcdir)/../Driver \
@@ -95,9 +96,7 @@ libSMESHimpl_la_CPPFLAGS = \
        -I$(srcdir)/../DriverUNV \
        -I$(srcdir)/../DriverSTL \
        -I$(srcdir)/../SMDS \
-       -I$(srcdir)/../SMESHDS \
-       -I$(top_builddir)/salome_adm/unix
-
+       -I$(srcdir)/../SMESHDS
 
 libSMESHimpl_la_LDFLAGS = \
        ../SMESHDS/libSMESHDS.la \
@@ -107,4 +106,4 @@ libSMESHimpl_la_LDFLAGS = \
        ../DriverMED/libMeshDriverMED.la \
        ../DriverUNV/libMeshDriverUNV.la \
        $(GEOM_LDFLAGS) -lNMTTools \
-       $(CAS_LDPATH) -lTKShHealing
+       $(CAS_LDPATH) -lTKShHealing -lTKPrim -lTKG2d