Salome HOME
PR: synchro V6_main tag mergeto_V7_main_11Feb13
[modules/smesh.git] / src / SMESH / Makefile.am
index c7c57ee3f29adcdcee2f747fc06b498edee84ec9..34086239638b14b88b119909d8fd278037704bf6 100644 (file)
@@ -1,20 +1,20 @@
-#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
 #  SMESH SMESH : implementaion of SMESH idl descriptions
@@ -22,7 +22,7 @@
 #  Author : Paul RASCLE, EDF
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : SMESH
-#
+
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
@@ -34,23 +34,12 @@ salomeinclude_HEADERS = \
        SMESH_Hypothesis.hxx \
        SMESH_HypoFilter.hxx \
        SMESH_Algo.hxx \
-       SMESH_0D_Algo.hxx \
-       SMESH_1D_Algo.hxx \
-       SMESH_2D_Algo.hxx \
-       SMESH_3D_Algo.hxx \
        SMESH_Group.hxx \
        SMESH_MeshEditor.hxx \
-       SMESH_Block.hxx \
        SMESH_Pattern.hxx \
-       SMESH_TypeDefs.hxx \
        SMESH_MesherHelper.hxx \
-       SMESH_Octree.hxx \
-       SMESH_OctreeNode.hxx \
-       SMESH_Comment.hxx \
-       SMESH_ComputeError.hxx \
-       SMESH_File.hxx \
-       SMESH_SMESH.hxx \
-       SMESH_ProxyMesh.hxx
+       SMESH_ProxyMesh.hxx \
+       SMESH_SMESH.hxx
 
 # Libraries targets
 
@@ -63,20 +52,12 @@ dist_libSMESHimpl_la_SOURCES = \
        SMESH_subMesh.cxx \
        SMESH_Hypothesis.cxx \
        SMESH_Algo.cxx \
-       SMESH_0D_Algo.cxx \
-       SMESH_1D_Algo.cxx \
-       SMESH_2D_Algo.cxx \
-       SMESH_3D_Algo.cxx \
        SMESH_Group.cxx \
        SMESH_MeshEditor.cxx \
-       SMESH_Block.cxx \
        SMESH_Pattern.cxx \
        SMESH_HypoFilter.cxx \
-       SMESH_MesherHelper.cxx \
-       SMESH_Octree.cxx \
-       SMESH_OctreeNode.cxx \
-       SMESH_File.cxx \
-       SMESH_ProxyMesh.cxx
+       SMESH_ProxyMesh.cxx \
+       SMESH_MesherHelper.cxx
 
 # additionnal information to compile and link file
 libSMESHimpl_la_CPPFLAGS = \
@@ -93,8 +74,15 @@ libSMESHimpl_la_CPPFLAGS = \
        -I$(srcdir)/../DriverMED \
        -I$(srcdir)/../DriverUNV \
        -I$(srcdir)/../DriverSTL \
+       -I$(srcdir)/../DriverCGNS \
+       -I$(srcdir)/../DriverGMF \
        -I$(srcdir)/../SMDS \
-       -I$(srcdir)/../SMESHDS
+       -I$(srcdir)/../SMESHDS \
+       -I$(srcdir)/../SMESHUtils
+
+if WITH_CGNS
+  DriverCGNS_LIB = ../DriverCGNS/libMeshDriverCGNS.la
+endif
 
 libSMESHimpl_la_LDFLAGS = \
        ../SMESHDS/libSMESHDS.la \
@@ -103,5 +91,10 @@ libSMESHimpl_la_LDFLAGS = \
        ../DriverSTL/libMeshDriverSTL.la \
        ../DriverMED/libMeshDriverMED.la \
        ../DriverUNV/libMeshDriverUNV.la \
+       ../DriverGMF/libMeshDriverGMF.la \
+       $(DriverCGNS_LIB) \
+       ../SMESHUtils/libSMESHUtils.la \
+       $(BOOST_LIB_THREAD)  \
+       $(BOOST_LIB_SYSTEM)  \
        $(GEOM_LDFLAGS) -lNMTTools \
-       $(CAS_LDPATH) -lTKShHealing -lTKPrim -lTKG2d
+       $(CAS_LDPATH) -lTKShHealing -lTKPrim -lTKG2d -lTKCDF