Salome HOME
0022104: EDF 2550 SMESH: 2D viscous layer, allow specifying edges with viscous layer
[modules/smesh.git] / src / SMESH / Makefile.am
index 8ea7e5734b8854f647ba120abbd2bac3dcd7b4d0..32ad95643c6b449e9aca83713acba7aaceff3cf6 100644 (file)
@@ -1,31 +1,27 @@
-#  SMESH SMESH : implementaion of SMESH idl descriptions
+# Copyright (C) 2007-2013  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS 
-# 
-#  This library is free software; you can redistribute it and/or 
-#  modify it under the terms of the GNU Lesser General Public 
-#  License as published by the Free Software Foundation; either 
-#  version 2.1 of the License. 
-# 
-#  This library is distributed in the hope that it will be useful, 
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of 
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
-#  Lesser General Public License for more details. 
-# 
-#  You should have received a copy of the GNU Lesser General Public 
-#  License along with this library; if not, write to the Free Software 
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA 
-# 
-# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+#
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
+#  SMESH SMESH : implementaion of SMESH idl descriptions
 #  File   : Makefile.in
 #  Author : Paul RASCLE, EDF
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : SMESH
-#  $Header$
 
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
@@ -38,23 +34,11 @@ salomeinclude_HEADERS = \
        SMESH_Hypothesis.hxx \
        SMESH_HypoFilter.hxx \
        SMESH_Algo.hxx \
-       SMESH_0D_Algo.hxx \
-       SMESH_1D_Algo.hxx \
-       SMESH_2D_Algo.hxx \
-       SMESH_3D_Algo.hxx \
        SMESH_Group.hxx \
        SMESH_MeshEditor.hxx \
-       SMESH_Block.hxx \
        SMESH_Pattern.hxx \
-       SMESH_IndexedDataMapOfShapeIndexedMapOfShape.hxx \
-       SMESH_DataMapOfElemPtrSequenceOfElemPtr.hxx \
-       SMESH_SequenceOfElemPtr.hxx \
-       SMESH_SequenceOfNode.hxx \
        SMESH_MesherHelper.hxx \
-       SMESH_Octree.hxx \
-       SMESH_OctreeNode.hxx \
-       SMESH_Comment.hxx \
-       SMESH_ComputeError.hxx \
+       SMESH_ProxyMesh.hxx \
        SMESH_SMESH.hxx
 
 # Libraries targets
@@ -62,31 +46,27 @@ salomeinclude_HEADERS = \
 lib_LTLIBRARIES = libSMESHimpl.la
 
 dist_libSMESHimpl_la_SOURCES = \
+       memoire.h \
        SMESH_Gen.cxx \
        SMESH_Mesh.cxx \
        SMESH_subMesh.cxx \
        SMESH_Hypothesis.cxx \
        SMESH_Algo.cxx \
-       SMESH_0D_Algo.cxx \
-       SMESH_1D_Algo.cxx \
-       SMESH_2D_Algo.cxx \
-       SMESH_3D_Algo.cxx \
        SMESH_Group.cxx \
        SMESH_MeshEditor.cxx \
-       SMESH_Block.cxx \
        SMESH_Pattern.cxx \
        SMESH_HypoFilter.cxx \
-       SMESH_MesherHelper.cxx \
-       SMESH_Octree.cxx \
-       SMESH_OctreeNode.cxx
+       SMESH_ProxyMesh.cxx \
+       SMESH_MesherHelper.cxx
 
 # additionnal information to compile and link file
 libSMESHimpl_la_CPPFLAGS = \
        $(KERNEL_CXXFLAGS) \
+       $(CAS_CPPFLAGS) \
        $(MED_CXXFLAGS) \
        $(GEOM_CXX_FLAGS) \
+        $(VTK_INCLUDES) \
        $(BOOST_CPPFLAGS) \
-       $(CAS_CPPFLAGS) \
        @HDF5_INCLUDES@ \
        -I$(srcdir)/../Controls \
        -I$(srcdir)/../Driver \
@@ -94,10 +74,15 @@ libSMESHimpl_la_CPPFLAGS = \
        -I$(srcdir)/../DriverMED \
        -I$(srcdir)/../DriverUNV \
        -I$(srcdir)/../DriverSTL \
+       -I$(srcdir)/../DriverCGNS \
+       -I$(srcdir)/../DriverGMF \
        -I$(srcdir)/../SMDS \
        -I$(srcdir)/../SMESHDS \
-       -I$(top_builddir)/salome_adm/unix
+       -I$(srcdir)/../SMESHUtils
 
+if WITH_CGNS
+  DriverCGNS_LIB = ../DriverCGNS/libMeshDriverCGNS.la
+endif
 
 libSMESHimpl_la_LDFLAGS = \
        ../SMESHDS/libSMESHDS.la \
@@ -106,5 +91,10 @@ libSMESHimpl_la_LDFLAGS = \
        ../DriverSTL/libMeshDriverSTL.la \
        ../DriverMED/libMeshDriverMED.la \
        ../DriverUNV/libMeshDriverUNV.la \
+       ../DriverGMF/libMeshDriverGMF.la \
+       $(DriverCGNS_LIB) \
+       ../SMESHUtils/libSMESHUtils.la \
+       $(BOOST_LIB_THREAD)  \
+       $(BOOST_LIB_SYSTEM)  \
        $(GEOM_LDFLAGS) -lNMTTools \
-       $(CAS_LDPATH) -lTKShHealing
+       $(CAS_LDPATH) -lTKShHealing -lTKPrim -lTKG2d -lTKCDF