Salome HOME
Update copyright
[modules/smesh.git] / src / SMDS / Makefile.am
index 9e945244719cbb85a9c0229f6698d678efa3a14f..34e8f9c01db8fb441670a1406304ea7bae061c8e 100644 (file)
@@ -1,24 +1,22 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2011  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 #  SMESH SMDS : implementaion of Salome mesh data structure
 #  File   : Makefile.in
 #  Author : Patrick GOLDBRONN (CEA)
@@ -29,19 +27,26 @@ include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
 salomeinclude_HEADERS = \
+    chrono.hxx \
+       ObjectPool.hxx \
        SMDS_TypeOfPosition.hxx \
        SMDSAbs_ElementType.hxx \
        SMDS_EdgePosition.hxx \
        SMDS_ElemIterator.hxx \
        SMDS_FacePosition.hxx \
        SMDS_Mesh.hxx \
+       SMDS_Mesh0DElement.hxx \
+       SMDS_LinearEdge.hxx \
        SMDS_MeshEdge.hxx \
        SMDS_MeshElement.hxx \
+       SMDS_MeshElement.cxx \
        SMDS_MeshElementIDFactory.hxx \
+       SMDS_MeshCell.hxx \
        SMDS_MeshFace.hxx \
        SMDS_MeshGroup.hxx \
        SMDS_MeshIDFactory.hxx \
        SMDS_MeshNode.hxx \
+       SMDS_MeshNodeIDFactory.hxx \
        SMDS_MeshObject.hxx \
        SMDS_MeshVolume.hxx \
        SMDS_Position.hxx \
@@ -51,6 +56,10 @@ salomeinclude_HEADERS = \
        SMDS_IteratorOfElements.hxx \
        SMDS_VolumeOfFaces.hxx \
        SMDS_VolumeOfNodes.hxx \
+       SMDS_VtkEdge.hxx \
+       SMDS_VtkFace.hxx \
+       SMDS_VtkVolume.hxx \
+       SMDS_VtkCellIterator.hxx \
        SMDS_PolyhedralVolumeOfNodes.hxx \
        SMDS_FaceOfEdges.hxx \
        SMDS_FaceOfNodes.hxx \
@@ -61,24 +70,33 @@ salomeinclude_HEADERS = \
        SMDS_QuadraticVolumeOfNodes.hxx \
        SMDS_SetIterator.hxx \
        SMESH_SMDS.hxx \
-       SMDS_MeshInfo.hxx
+       SMDS_MeshInfo.hxx \
+       SMDS_UnstructuredGrid.hxx \
+       SMDS_Downward.hxx \
+       SMDS_StdIterator.hxx \
+       SMDS_IteratorOnIterators.hxx
 
 
 # Libraries targets
 
 lib_LTLIBRARIES = libSMDS.la
 dist_libSMDS_la_SOURCES = \
+    chrono.cxx \
        SMDS_MeshObject.cxx \
        SMDS_MeshElement.cxx \
+       SMDS_MeshCell.cxx \
        SMDS_Position.cxx \
        SMDS_EdgePosition.cxx \
        SMDS_FacePosition.cxx \
        SMDS_SpacePosition.cxx \
        SMDS_VertexPosition.cxx \
        SMDS_MeshNode.cxx \
+       SMDS_Mesh0DElement.cxx \
+       SMDS_LinearEdge.cxx \
        SMDS_MeshEdge.cxx \
        SMDS_MeshFace.cxx \
        SMDS_MeshVolume.cxx \
+       SMDS_MeshNodeIDFactory.cxx \
        SMDS_MeshElementIDFactory.cxx \
        SMDS_MeshGroup.cxx \
        SMDS_MeshIDFactory.cxx \
@@ -86,6 +104,10 @@ dist_libSMDS_la_SOURCES = \
        SMDS_IteratorOfElements.cxx \
        SMDS_VolumeOfFaces.cxx \
        SMDS_VolumeOfNodes.cxx \
+       SMDS_VtkEdge.cxx \
+       SMDS_VtkFace.cxx \
+       SMDS_VtkVolume.cxx \
+       SMDS_VtkCellIterator.cxx \
        SMDS_PolyhedralVolumeOfNodes.cxx \
        SMDS_FaceOfEdges.cxx \
        SMDS_FaceOfNodes.cxx \
@@ -93,15 +115,19 @@ dist_libSMDS_la_SOURCES = \
        SMDS_VolumeTool.cxx \
        SMDS_QuadraticEdge.cxx \
        SMDS_QuadraticFaceOfNodes.cxx \
-       SMDS_QuadraticVolumeOfNodes.cxx
+       SMDS_QuadraticVolumeOfNodes.cxx \
+       SMDS_UnstructuredGrid.cxx \
+       SMDS_Downward.cxx
 
 # additionnal information to compil and link file
 libSMDS_la_CPPFLAGS = \
        $(KERNEL_CXXFLAGS) \
        $(CAS_CPPFLAGS) \
+        $(VTK_INCLUDES) \
        $(BOOST_CPPFLAGS)
 
 libSMDS_la_LDFLAGS  = \
+       $(VTK_LIBS) \
        $(KERNEL_LDFLAGS) -lSALOMELocalTrace \
        $(CAS_KERNEL)
 
@@ -112,3 +138,5 @@ dist_SMDS_MemoryLimit_SOURCES = \
 
 SMDS_MemoryLimit_LDADD = \
        $(KERNEL_LDFLAGS) -lSALOMELocalTrace
+
+#libSMDS_la_LDFLAGS += -L/data/eap/S5_MV/INSTALL/SMESH/lib/salome -lPerfmeter