Salome HOME
Copyright update 2021
[modules/smesh.git] / src / SMDS / CMakeLists.txt
index 867e0b2df194abcbc508a3131744dfbe20e56125..d58eaa9427dea4625af1d02ff3a5e826dba834d4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2019  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2021  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -21,7 +21,6 @@
 # additional include directories
 INCLUDE_DIRECTORIES(
   ${KERNEL_INCLUDE_DIRS}
-  ${VTK_INCLUDE_DIRS}
   ${Boost_INCLUDE_DIRS}
 )
 
@@ -32,9 +31,10 @@ ADD_DEFINITIONS(
 
 # libraries to link to
 SET(_link_LIBRARIES
-  ${VTK_LIBRARIES}
   ${KERNEL_SALOMELocalTrace}
   ${KERNEL_OpUtil}
+  VTK::CommonCore
+  VTK::CommonDataModel
 )
 
 # --- headers ---