Salome HOME
Fix for the bug "21427: EDF 2024 SMESH: numbering does not take into account clipping".
[modules/smesh.git] / src / OBJECT / Makefile.am
index 7a6a7b70fa5f8d03a27518902ba3d2590f61f566..6b38c0ca43dd8974f880bac823579ec2c6423be3 100644 (file)
@@ -1,24 +1,22 @@
-#  Copyright (C) 2007-2008  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2011  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  Copyright (C) 2003-2007  OPEN CASCADE, EADS/CCR, LIP6, CEA/DEN,
-#  CEDRAT, EDF R&D, LEG, PRINCIPIA R&D, BUREAU VERITAS
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
-#
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
+
 #  SMESH OBJECT : interactive object for SMESH visualization
 #  File   : Makefile.in
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
@@ -36,8 +34,10 @@ salomeinclude_HEADERS = \
        SMESH_DeviceActor.h \
        SMESH_PreviewActorsCollection.h \
        SMESH_ExtractGeometry.h \
-       SMESH_ActorUtils.h \
-       SMESH_FaceOrientationFilter.h
+       SMESH_FaceOrientationFilter.h \
+       SMESH_ScalarBarActor.h \
+       SMESH_NodeLabelActor.h \
+       SMESH_CellLabelActor.h
 
 # Libraries targets
 
@@ -49,13 +49,17 @@ dist_libSMESHObject_la_SOURCES = \
        SMESH_PreviewActorsCollection.cxx \
        SMESH_ExtractGeometry.cxx \
        SMESH_ActorUtils.cxx \
-       SMESH_FaceOrientationFilter.cxx
+       SMESH_FaceOrientationFilter.cxx \
+       SMESH_ScalarBarActor.cxx \
+       SMESH_NodeLabelActor.cxx \
+       SMESH_CellLabelActor.cxx 
 
 libSMESHObject_la_CPPFLAGS = \
         $(QT_INCLUDES) \
         $(KERNEL_CXXFLAGS) \
         $(GUI_CXXFLAGS) \
        $(MED_CXXFLAGS) \
+       $(QWT_INCLUDES) \
        $(GEOM_CXXFLAGS) \
        $(CAS_CPPFLAGS) \
         $(VTK_INCLUDES) \
@@ -76,7 +80,9 @@ libSMESHObject_la_LDFLAGS  = \
         ../SMESHClient/libSMESHClient.la \
         ../SMDS/libSMDS.la \
         ../Controls/libSMESHControls.la \
-        $(GUI_LDFLAGS) -lSalomeApp -lSalomeObject -lSVTK -lVTKViewer -lqtx -lsuit \
+        $(GUI_LDFLAGS) -lSalomeApp -lSalomeObject -lSVTK -lVTKViewer -lqtx -lsuit -lstd \
+       -lPlot2d \
+       -lSPlot2d \
        $(GEOM_LDFLAGS) -lGEOMObject \
        $(CAS_KERNEL) \
         $(VTK_LIBS) $(QT_MT_LIBS)