Salome HOME
Implementation of the "21459: EDF 1495 SMESH: Manipulation of discrete elements with...
[modules/smesh.git] / src / OBJECT / Makefile.am
index 88dd738fde9076d5222de75aa6f92281ff8d3284..59cf1400c2bdd61cc5c0753eca4e910990ca5146 100644 (file)
@@ -1,20 +1,20 @@
-#  Copyright (C) 2007-2010  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
 #
-#  This library is free software; you can redistribute it and/or
-#  modify it under the terms of the GNU Lesser General Public
-#  License as published by the Free Software Foundation; either
-#  version 2.1 of the License.
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License.
 #
-#  This library is distributed in the hope that it will be useful,
-#  but WITHOUT ANY WARRANTY; without even the implied warranty of
-#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-#  Lesser General Public License for more details.
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# Lesser General Public License for more details.
 #
-#  You should have received a copy of the GNU Lesser General Public
-#  License along with this library; if not, write to the Free Software
-#  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
-#  See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
+# See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
 #  SMESH OBJECT : interactive object for SMESH visualization
@@ -35,7 +35,11 @@ salomeinclude_HEADERS = \
        SMESH_PreviewActorsCollection.h \
        SMESH_ExtractGeometry.h \
        SMESH_FaceOrientationFilter.h \
-       SMESH_ScalarBarActor.h
+       SMESH_ScalarBarActor.h \
+       SMESH_NodeLabelActor.h \
+       SMESH_CellLabelActor.h \
+       SMESH_SVTKActor.h 
+
 
 # Libraries targets
 
@@ -48,13 +52,17 @@ dist_libSMESHObject_la_SOURCES = \
        SMESH_ExtractGeometry.cxx \
        SMESH_ActorUtils.cxx \
        SMESH_FaceOrientationFilter.cxx \
-       SMESH_ScalarBarActor.cxx
+       SMESH_ScalarBarActor.cxx \
+       SMESH_NodeLabelActor.cxx \
+       SMESH_CellLabelActor.cxx \
+       SMESH_SVTKActor.cxx 
 
 libSMESHObject_la_CPPFLAGS = \
         $(QT_INCLUDES) \
         $(KERNEL_CXXFLAGS) \
         $(GUI_CXXFLAGS) \
        $(MED_CXXFLAGS) \
+       $(QWT_INCLUDES) \
        $(GEOM_CXXFLAGS) \
        $(CAS_CPPFLAGS) \
         $(VTK_INCLUDES) \
@@ -69,13 +77,16 @@ libSMESHObject_la_CPPFLAGS = \
        -I$(srcdir)/../DriverMED \
        -I$(srcdir)/../SMESH \
        -I$(srcdir)/../SMESHClient \
+       -I$(srcdir)/../SMESHUtils \
        -I$(top_builddir)/idl
 
 libSMESHObject_la_LDFLAGS  = \
         ../SMESHClient/libSMESHClient.la \
         ../SMDS/libSMDS.la \
         ../Controls/libSMESHControls.la \
-        $(GUI_LDFLAGS) -lSalomeApp -lSalomeObject -lSVTK -lVTKViewer -lqtx -lsuit \
+        $(GUI_LDFLAGS) -lSalomeApp -lSalomeObject -lSVTK -lVTKViewer -lqtx -lsuit -lstd \
+       -lPlot2d \
+       -lSPlot2d \
        $(GEOM_LDFLAGS) -lGEOMObject \
        $(CAS_KERNEL) \
         $(VTK_LIBS) $(QT_MT_LIBS)