Salome HOME
Merge branch 'V9_9_BR'
[modules/smesh.git] / src / OBJECT / CMakeLists.txt
index 21b5ead3f66025c00c87508644667c3db78c1b4c..d15e509d414094bff4173645f405ab316ad58e9b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2022  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
@@ -26,7 +26,6 @@ INCLUDE_DIRECTORIES(
   ${QWT_INCLUDE_DIR}
   ${GEOM_INCLUDE_DIRS}
   ${OpenCASCADE_INCLUDE_DIR}
-  ${VTK_INCLUDE_DIRS}
   ${OMNIORB_INCLUDE_DIR}
   ${Boost_INCLUDE_DIRS}
   ${PROJECT_SOURCE_DIR}/src/Controls
@@ -50,19 +49,19 @@ ADD_DEFINITIONS(
 # libraries to link to
 SET(_link_LIBRARIES
   ${QT_LIBRARIES}
-  ${VTK_LIBRARIES}
   ${OpenCASCADE_KERNEL}
   ${GEOM_GEOMObject}
-  ${GUI_SalomeApp}
   ${GUI_SalomeObject}
   ${GUI_SVTK}
   ${GUI_VTKViewer}
   ${GUI_qtx}
   ${GUI_suit}
   ${GUI_std}
+  ${GUI_SalomeApp}
   SMESHClient
   SMDS
   SMESHControls
+  VTK::RenderingLabel
 )
 
 IF(SALOME_USE_PLOT2DVIEWER)
@@ -79,6 +78,7 @@ SET(SMESHObject_HEADERS
   SMESH_Actor.h
   SMESH_Object.h
   SMESH_ObjectDef.h
+  SMESH_ActorProps.h
   SMESH_ActorUtils.h
   SMESH_ActorDef.h
   SMESH_DeviceActor.h
@@ -98,6 +98,7 @@ SET(SMESHObject_SOURCES
   SMESH_Object.cxx
   SMESH_DeviceActor.cxx
   SMESH_Actor.cxx
+  SMESH_ActorProps.cxx
   SMESH_PreviewActorsCollection.cxx
   SMESH_ExtractGeometry.cxx
   SMESH_ActorUtils.cxx