Salome HOME
Merge remote branch 'origin/gdd/translations'
[modules/smesh.git] / src / MEFISTO2 / CMakeLists.txt
index cd8bd1f9cf0f91262d19556342e657c134991648..72ed216e5b20ab972a65b824c562d663c9359367 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2015  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -88,10 +88,14 @@ ENDIF(${F2C_FOUND})
 ADD_LIBRARY(MEFISTO2D ${MEFISTO2D_SOURCES})
 TARGET_LINK_LIBRARIES(MEFISTO2D ${_link_LIBRARIES} )
 
-#Ignore MSVCRT.lib on WIN32 in case using f2c code generator
-IF(WIN32 AND ${F2C_FOUND})
-  SET_TARGET_PROPERTIES(MEFISTO2D PROPERTIES LINK_FLAGS "/NODEFAULTLIB:MSVCRT")
-ENDIF(WIN32 AND ${F2C_FOUND})
+#Ignore MSVCRT.lib on WINDOWS in case using f2c code generator
+IF(WIN32)
+  IF(CMAKE_BUILD_TYPE STREQUAL Debug)
+    IF(${F2C_FOUND})
+      SET_TARGET_PROPERTIES(MEFISTO2D PROPERTIES LINK_FLAGS "/NODEFAULTLIB:MSVCRT")
+    ENDIF(${F2C_FOUND})
+  ENDIF()
+ENDIF(WIN32)
 
 INSTALL(TARGETS MEFISTO2D EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 INSTALL(FILES ${MEFISTO2D_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})