Salome HOME
bos #24257 [CEA] Fatal error when creating a submesh if the mesh is on a sub-shape
[modules/smesh.git] / src / MEDWrapper / CMakeLists.txt
index 90ed5a20a7d0e09ee75d05ae1ec00077ecef2b40..7c3478e240988d768e17e8496a58b88f0ca457b3 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D
+# Copyright (C) 2012-2021  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
 # See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
-ADD_SUBDIRECTORY(Base)
-ADD_SUBDIRECTORY(V2_2)
-ADD_SUBDIRECTORY(Factory)
+# --- options ---
+# additional include directories
+INCLUDE_DIRECTORIES(
+  ${Boost_INCLUDE_DIRS}
+  ${HDF5_INCLUDE_DIRS}
+  ${MEDFILE_INCLUDE_DIRS}
+  ${KERNEL_INCLUDE_DIRS}
+)
+
+# additional preprocessor / compiler flags
+ADD_DEFINITIONS(
+  ${BOOST_DEFINITIONS}
+  ${HDF5_DEFINITIONS}
+)
+
+SET(_link_LIBRARIES
+  ${Boost_LIBRARIES}
+  ${HDF5_LIBS}
+  ${MEDFILE_C_LIBRARIES}
+  ${KERNEL_SALOMELocalTrace}
+)
+
+# --- headers ---
+
+# header files / no moc processing
+SET(MEDWrapper_HEADERS
+  MED_Algorithm.hxx
+  MED_Common.hxx
+  MED_CoordUtils.hxx
+  MED_Factory.hxx
+  MED_GaussDef.hxx
+  MED_GaussUtils.hxx
+  MED_SharedPtr.hxx
+  MED_SliceArray.hxx
+  MED_Structures.hxx
+  MED_TStructures.hxx
+  MED_Utilities.hxx
+  MED_Vector.hxx
+  MED_Wrapper.hxx
+  MED_WrapperDef.hxx
+)
+
+# --- sources ---
+
+# sources / static
+SET(MEDWrapper_SOURCES
+  MED_Algorithm.cxx
+  MED_Common.cxx
+  MED_CoordUtils.cxx
+  MED_Factory.cxx
+  MED_GaussDef.cxx
+  MED_GaussUtils.cxx
+  MED_Structures.cxx
+  MED_Utilities.cxx
+  MED_Wrapper.cxx
+)
+
+# --- rules ---
+
+ADD_LIBRARY(MEDWrapper ${MEDWrapper_SOURCES})
+TARGET_LINK_LIBRARIES(MEDWrapper ${_link_LIBRARIES})
+INSTALL(TARGETS MEDWrapper EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
+
+ADD_EXECUTABLE(mprint_version mprint_version.cxx)
+TARGET_LINK_LIBRARIES(mprint_version ${MEDFILE_C_LIBRARIES})
+INSTALL(TARGETS mprint_version EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_BINS})
+
+INSTALL(FILES ${MEDWrapper_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})