Salome HOME
Add documentation fallbacks
[modules/smesh.git] / src / MEDWrapper / CMakeLists.txt
index 15d0610b69075cafbcaa7d1118ab2995ed302733..4e3bca1ed3b10549d69cc9fe87ef231a6a1c67ba 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2015  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2016  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
 #
 
-ADD_SUBDIRECTORY(Base)
-ADD_SUBDIRECTORY(V2_2)
-ADD_SUBDIRECTORY(Factory)
+# --- options ---
+# additional include directories
+INCLUDE_DIRECTORIES(
+  ${Boost_INCLUDE_DIRS}
+  ${HDF5_INCLUDE_DIRS}
+  ${MEDFILE_INCLUDE_DIRS}
+  ${KERNEL_INCLUDE_DIRS}
+)
+
+# additional preprocessor / compiler flags
+ADD_DEFINITIONS(
+  ${BOOST_DEFINITIONS}
+  ${HDF5_DEFINITIONS}
+)
+
+SET(_link_LIBRARIES
+  ${Boost_LIBRARIES}
+  ${HDF5_LIBS}
+  ${MEDFILE_C_LIBRARIES}
+)
+
+# --- headers ---
+
+# header files / no moc processing
+SET(MEDWrapper_HEADERS
+  MED_Algorithm.hxx
+  MED_Common.hxx
+  MED_CoordUtils.hxx
+  MED_Factory.hxx
+  MED_GaussDef.hxx
+  MED_GaussUtils.hxx
+  MED_SharedPtr.hxx
+  MED_SliceArray.hxx
+  MED_Structures.hxx
+  MED_TStructures.hxx
+  MED_Utilities.hxx
+  MED_Vector.hxx
+  MED_Wrapper.hxx
+  MED_WrapperDef.hxx
+)
+
+# --- sources ---
+
+# sources / static
+SET(MEDWrapper_SOURCES
+  MED_Algorithm.cxx
+  MED_Common.cxx
+  MED_CoordUtils.cxx
+  MED_Factory.cxx
+  MED_GaussDef.cxx
+  MED_GaussUtils.cxx
+  MED_Structures.cxx
+  MED_Utilities.cxx
+  MED_Wrapper.cxx
+)
+
+# --- rules ---
+
+ADD_LIBRARY(MEDWrapper ${MEDWrapper_SOURCES})
+TARGET_LINK_LIBRARIES(MEDWrapper ${_link_LIBRARIES})
+INSTALL(TARGETS MEDWrapper EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
+
+ADD_EXECUTABLE(mprint_version mprint_version.cxx)
+TARGET_LINK_LIBRARIES(mprint_version ${MEDFILE_C_LIBRARIES})
+INSTALL(TARGETS mprint_version EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_BINS})
+
+INSTALL(FILES ${MEDWrapper_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})