Salome HOME
Merge remote branch 'origin/gdd/translations'
[modules/smesh.git] / src / DriverSTL / CMakeLists.txt
index 71abee231a5f659e3c73322e724ac53f6d01228a..74e7232be138bd4b856ae293b5cecb54b0d4096e 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2012-2013  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2012-2015  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # License as published by the Free Software Foundation; either
-# version 2.1 of the License.
+# version 2.1 of the License, or (at your option) any later version.
 #
 # This library is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -45,6 +45,7 @@ SET(_link_LIBRARIES
   ${KERNEL_SALOMEBasics}
   MeshDriver
   SMDS
+  SMESHUtils
 )
 
 SET(_link_LIBRARIES_bin
@@ -78,19 +79,10 @@ SET(MeshDriverSTL_SOURCES
   DriverSTL_W_SMDS_Mesh.cxx
 )
 
-# bin programs
-SET(STL_Test_SOURCES
-  STL_Test.cxx
-)
-
 # --- rules ---
 
 ADD_LIBRARY(MeshDriverSTL ${MeshDriverSTL_SOURCES})
 TARGET_LINK_LIBRARIES(MeshDriverSTL ${_link_LIBRARIES} )
 INSTALL(TARGETS MeshDriverSTL EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_LIBS})
 
-ADD_EXECUTABLE(STL_Test ${STL_Test_SOURCES})
-TARGET_LINK_LIBRARIES(STL_Test ${_link_LIBRARIES_bin} MeshDriverSTL)
-INSTALL(TARGETS STL_Test EXPORT ${PROJECT_NAME}TargetGroup DESTINATION ${SALOME_INSTALL_BINS})
-
 INSTALL(FILES ${MeshDriverSTL_HEADERS} DESTINATION ${SALOME_INSTALL_HEADERS})