Salome HOME
-#if OCC_VERSION_LARGE > 0x06010000
[modules/smesh.git] / src / DriverMED / Makefile.am
index 898952af77ff2948b7bfdc21933b42eb1f692ac8..95b5a01533c48381ee18a688b717166fb4386d2a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2007-2012  CEA/DEN, EDF R&D, OPEN CASCADE
+# Copyright (C) 2007-2013  CEA/DEN, EDF R&D, OPEN CASCADE
 #
 # This library is free software; you can redistribute it and/or
 # modify it under the terms of the GNU Lesser General Public
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
 #
 # See http://www.salome-platform.org/ or email : webmaster.salome@opencascade.com
-#
 
 #  SMESH DriverMED : driver to read and write 'med' files
 #  File   : Makefile.in
 #  Author : Marc Tajchman (CEA)
 #  Modified by : Alexander BORODIN (OCN) - autotools usage
 #  Module : SMESH
-#  $Header$
 #
 include $(top_srcdir)/adm_local/unix/make_common_starter.am
 
 # header files 
 salomeinclude_HEADERS = \
+       DriverMED.hxx \
        DriverMED_R_SMESHDS_Mesh.h \
        DriverMED_W_SMESHDS_Mesh.h \
        DriverMED_Family.h \
@@ -49,21 +48,25 @@ dist_MED_Test_SOURCES = \
 
 # additionnal information to compil and link file
 libMeshDriverMED_la_CPPFLAGS = \
-       $(MED_CXXFLAGS) \
        @HDF5_INCLUDES@ \
        $(KERNEL_CXXFLAGS) \
        $(CAS_CPPFLAGS) \
         $(VTK_INCLUDES) \
        $(BOOST_CPPFLAGS) \
+       -I$(srcdir)/../MEDWrapper/Base \
+       -I$(srcdir)/../MEDWrapper/Factory \
        -I$(srcdir)/../Driver \
        -I$(srcdir)/../SMDS \
+       -I$(srcdir)/../SMESHUtils \
        -I$(srcdir)/../SMESHDS
 
 libMeshDriverMED_la_LDFLAGS  = \
        $(BOOST_LIBS) \
        ../Driver/libMeshDriver.la \
-       $(MED_LDFLAGS) -lMEDWrapper -lMEDWrapperBase -lMEDWrapper_V2_2 -lMEDWrapper_V2_1
-
+       ../MEDWrapper/Factory/libMEDWrapper.la \
+       ../MEDWrapper/Base/libMEDWrapperBase.la \
+       ../MEDWrapper/V2_2/libMEDWrapper_V2_2.la \
+       $(BOOST_LIB_SYSTEM) 
 
 MED_Test_CPPFLAGS = \
        $(libMeshDriverMED_la_CPPFLAGS)
@@ -73,13 +76,13 @@ MED_Test_LDADD = \
        ../Driver/libMeshDriver.la \
        ../SMDS/libSMDS.la \
        ../SMESHDS/libSMESHDS.la \
+       ${BOOST_LIB_SYSTEM} \
        $(KERNEL_LDFLAGS) \
        -lOpUtil \
        -lSALOMELocalTrace \
        -lSALOMEBasics \
-       $(MED_LDFLAGS) \
-       -lMEDWrapper \
-       -lMEDWrapperBase \
-       -lMEDWrapper_V2_2 \
-       -lMEDWrapper_V2_1 
-
+       -lSalomeIDLKernel \
+       ../MEDWrapper/Factory/libMEDWrapper.la \
+       ../MEDWrapper/Base/libMEDWrapperBase.la \
+       ../MEDWrapper/V2_2/libMEDWrapper_V2_2.la \
+       $(BOOST_LIB_SYSTEM)